Bug in signature-function when reply with multiple identities

RESOLVED DUPLICATE of bug 218346

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 218346
12 years ago
12 years ago

People

(Reporter: m0in, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Opera/8.02 (Windows NT 5.0; U; de)
Build Identifier: Version 1.0.6 (20050716)

Hello,
sorry, but my english is not the best and i use a german-version of thunderbird, 
so some menu-item that i describe in the follow could have the wrong name.
And here the problem:

- i have one mail-account with two identities and tow different signatures.

- at "accounts", "addressing and compose" a have activated for both of the 
identities: quote original mail. And there: "answer above the original mail" an 
"signature under my answer but above the quoting"

- now i get an emal. i click on reply.

- the window to write the mail appears correct with the signatur of the one 
identity.

- now i change in the mail-windows in the drop-down "from" (or "by") the 
identity to the second.

- and the problem now: the first-identity-signature won't be deleted and 
replaced by the second-one but set above the first signature. so, when you 
change your identities several times, there will be a long list of alternating 
signatures.

- but if i wrote a new mail, the signature-changing act correct. that means: 
thunderbird knows where it has wrote the first signature and delete and replace 
this by the second signature.


Reproducible: Always

Steps to Reproduce:
1. create two identities with two different signatures
2. set at "accounts", "addressing and compose" for both of the identities: quote 
original mail. And there: "answer above the original mail" an "signature under 
my answer bit above the quoting"
3. reply on a mail
4. change the identity with the from-drop-down on top.
5. lock at the two different signatures among themselves
6. repeat 4. and 5. to have a long list of alternating signatures
Actual Results:  
the first-identity-signature won't be deleted and replaced by the second-one but 
set above the first signature. so, when you change your identities several 
times, there will be a long list of alternating signatures.

Expected Results:  
thunderbird should knows where it has wrote the first signature and delete and 
replace this by the second signature.

my system: Win2K, SP4

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 218346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.