If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Checking Completed on a recurring stops it's recurrence.

VERIFIED DUPLICATE of bug 194556

Status

Calendar
General
--
enhancement
VERIFIED DUPLICATE of bug 194556
12 years ago
12 years ago

People

(Reporter: Jacob Gest, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When one creates a task and sets it to be recurring forever, lets say every day,
one can not check on the box in the task list and have the task show up the next
day. Since the whole point of a recurring task would be that it occurs multiple
times, but still needs completion each time it occurs, checking the task off as
completed should only record that occurrence as completed rather than the entire
series of occurrences. 

Reproducible: Always

Steps to Reproduce:
1. Create a task that recurs once every day forever
2. check the completed box in the task list
3. open calendar back up the following day
Actual Results:  
Task is still marked as completed

Expected Results:  
Keep the task as due for the day.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 194556 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.