Buttons don't un-hilight when mouse leaves them while mouse is down

VERIFIED DUPLICATE of bug 30384

Status

()

Core
XUL
P3
normal
VERIFIED DUPLICATE of bug 30384
19 years ago
19 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] fix in hand.)

(Assignee)

Description

19 years ago
- click in a button, like the "OK" button of prefs window
- while the mouse is down, move the mouse out of the button

expected:
- button returns to normal state

actual:
- button still looks depressed even though releasing the mouse will not click the 
button
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Whiteboard: fix in hand.

Comment 1

19 years ago
PDT+ just because I can
Keywords: beta1
Whiteboard: fix in hand. → [PDT+] fix in hand.

Comment 2

19 years ago
This needs to happen for all widgets, not just unhighlighting, but tracking 
while the mouse stays down, and continuing to change state on 
mouseover/mouseout.  Do we really want to hold PR1 for this level of problem?  
BTW, this is actually a dup of 30384, which nobody even marked beta1.
(Assignee)

Comment 3

19 years ago
oh, heh. forgot to mark this fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
Reopening for linux only. Specificially for _buttons_ (and leaving the
complete set of widgets to bug #30384), this works for :
  win98   2000030813
  mac 8.6 2000030813
but does not work for :
  linux (rh 6.0) 2000030809

(I note though that nav4.x on linux (motif), and the GTK widgets for
other apps have a dual nature for this type of (mousedown + mouseout)
-- the button goes up on mouseout, but some form of widget outline is
left active).

I don't know if this should remain as PDT+, given the above and that
it is fixed on win32 and mac.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

19 years ago
this bug was just a quickie to make us look less like complete dopes for beta. if 
it's not perfect for gtk's variation of buttons, that's not the purpose of this 
bug. marking a dupe of 30384 to get it off the radar.


*** This bug has been marked as a duplicate of 30384 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
verify that this is a duplicate of #30384
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.