memory leak, uses up to 125Mb of ram with V1.5 beta 1

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
12 years ago
12 years ago

People

(Reporter: Nathan Organ, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

when i had ebay open for a while (i leaveit for days sometimes) i noticed it
using quite a bit of memory, approximately 125mb's. 
after opening ie to see what it's usage was, i then closed firefox and opened
again and compare the 2 with ebay open on my selling manager screen.

it's now only using 34mb with this page open.

Reproducible: Didn't try

Steps to Reproduce:
1.open ebay and leave open for up to a week.
2.
3.



Expected Results:  
released memory

Comment 1

12 years ago
Most likely due to Java

Comment 2

12 years ago
I've had memory leak issues before, but the 1.5.1 beta is really bad.  Firefox now regularly baloons up in memory.  When I check it in the Task Manager I can see it snowballing.  This and I only have 12 tabs open.  It causes everything to be unresponsive.  I right click for the context menu, wait... I click on another tab, wait...  and so on.

Comment 3

12 years ago
memory leak occurs everytime I leave Firefox open over a work weekend. Unable to do anything except use TaskManager to shut Firefox down. Occurs with no tabs open or multiple tabs. Never happened until version 1.5.0.1

Comment 4

12 years ago
I started noticing this a couple days ago.  I was running Firefox 1.51 and Firefox was using between 80bm to 130mb of memory, and ~99% of my CPU power constantly.
I open up Firefox and it starts at 30mb and just keeps shooting upwards.
I have tried Deer Park 2 with the same problem.  I have tried one of those fixes that limits the cache or something and it didn't help at all.
I am running Windows 2003.
I'd appreciate somebody changing the "Secerity" of this bug to Critical.  It makes Firefox unusable ever.

Comment 5

12 years ago
Without specific reproducible problems, this bug isn't of any real value.

Please read http://dbaron.org/log/2006-01#e20060110a and http://forums.mozillazine.org/viewtopic.php?t=354828 before filing bugs about memory leaks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.