Closed Bug 309140 Opened 14 years ago Closed 14 years ago

Fix help button placement under UNIX

Categories

(Firefox :: Preferences, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: mefoster, Assigned: mconnor)

Details

(Keywords: fixed1.8)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

In Linux Firefox 1.5 Beta 1, the "Edit / Preferences" dialogue box has two
buttons on it: "Help" and "Close". These are placed on the lower right of the
dialogue box, and look a *lot* like they should be "OK" and "Cancel" if you
don't look too closely at them. The result is that, almost every time I change
my preferences, I end up inadvertently opening the help because I clicked on the
"Help" button in an attempt to dismiss the window.

Maybe "Help" could be over on the left instead of on the right next to "Close"?

Reproducible: Always

Steps to Reproduce:
1. Choose "Edit / Preferences" from the menu
2. Change some preferences
3. Try to close window by clicking on most obvious button
Actual Results:  
Help opens, because I ended up clicking on "Help"

Expected Results:  
Not put the "Help" button where it looks like an "OK" button
Help should be on the left for GNOME, per the HIG, but we have some issues
there.  Patch upcoming.
Assignee: nobody → mconnor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "Edit / Preferences" dialogue box buttons are confusingly located → Fix help button placement under UNIX
Attached patch first cutSplinter Review
needs mac testing
Comment on attachment 196674 [details] [diff] [review]
first cut

This moves the Help button on Mac to the bottom left in all cases, not just
where there's other buttons.  The behaviour without other buttons present isn't
specified in the HIG, and seems more like a flaw in the native widget than a
reasoned discussion.
Attachment #196674 - Flags: review?(bugs.mano)
Comment on attachment 196674 [details] [diff] [review]
first cut

r=mano on the toolkit/ changes.
Attachment #196674 - Flags: review?(bugs.mano) → review+
Comment on attachment 196674 [details] [diff] [review]
first cut

subtle alignment stuff, not risky/well tested
Attachment #196674 - Flags: approval1.8b5?
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Comment on attachment 196674 [details] [diff] [review]
first cut

Approved per 9/26 bug triage meeting.
Attachment #196674 - Flags: approval1.8b5? → approval1.8b5+
Flags: blocking1.8b5+
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.