Display issue when position: absolute is used.

RESOLVED WORKSFORME

Status

()

Firefox
General
--
trivial
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Russell Woodward, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When a webpage includes a large image and a html object with "position:
absolute;" as the style, the browser does not render the object's position
correctly.

Reproducible: Always

Steps to Reproduce:
1. Go to
http://www.opodo.co.uk/otpbvpl/Jsp/opodo/StrutsServlet/GetAvailability?hotelCode=19176&numOfAdults=1&numOfChildren=0&refPage=hotelDetails&chainCode=&checkInDate=&numOfRooms=1&checkOutDate=&brandCode=
with Firefox (using 1.06) and scroll down to the "Dates" section.
Actual Results:  
The "day" being displayed is hovering further up the page than intended. If you
put your cursor over the day field it will drop down the page and display in the
correct location (as a JS function is being called). Refreshing the page will
cause the day to be in out of alignment once again. 

Expected Results:  
The "day" being displayed should be aligned next to the month <select> object.

This is what seems to be happening:

1. Page is requested, the html is output to the browser, the day is aligned
correctly and the large image is requested from the server.

2. Once the image is loaded the page is rendered correctly by pushing down the
content so the image can fit in the location where it is to be placed on the page.

3. All content is pushed down EXCEPT an object with "position: absolute;" as its
style. Firefox seems to forget to render this object when images are loaded and
placed on the page.

Although the structure of the code is very poor, I have reproduced this bug by
removing all html apart from the hotel image and the dates section from the page
and saved it to my desktop. The code was valid html but the bug was still able
to be reproduced.

Comment 1

13 years ago
Reproducible with Mozilla 1.7.10 but WFM with Mozilla 1.8b1 and Firefox 1.5b1.

Comment 2

12 years ago
I was finding that this bug happens when I had an <a> with display:inline somewhere earlier.

I worked around it by wrapping the <a> in a <div>.

inline seems to have been doing something bad.

Anyway, this seems to be fixed with FF 1.5.

Comment 3

12 years ago
marking WFM per above comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.