If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"All Day" events cropped in Week View

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: jrx, Assigned: Mostafa Hosseini)

Tracking

Details

Attachments

(1 attachment)

1.69 KB, patch
Michiel van Leeuwen (email: mvl+moz@)
: first-review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050916 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050918 Mozilla Sunbird/0.2+

In Week View, "All Day" events are cropped to the first two letters.

Reproducible: Always

Steps to Reproduce:
1.Create all day event
2.Switch to week view
3.

Actual Results:  
Cropped event

Expected Results:  
Display the event title along the whole width of the column for that day.

Comment 1

12 years ago
Confirming.  See Bug 306644 comment #3.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
Created attachment 196755 [details] [diff] [review]
better elementOfRef

As I said in the comment on the previous bug, since all-day events have a
start-hour of midnight, the patch there causes an proper ElementOfRef to no
longer be found.  The element that is found is collapsed, and hence has no
width.	This patch checks for that case, and then gets an element of reference
based on the view limit default, which will always be visible.
Attachment #196755 - Flags: first-review?(mvl)
Comment on attachment 196755 [details] [diff] [review]
better elementOfRef

Why not always use sHour? That should always be visible, right? Hmm, it might
be faster not to ask the pref service.
Do what you think is best. r=mvl
Attachment #196755 - Flags: first-review?(mvl) → first-review+

Comment 4

12 years ago
Patch checked in, without changes.  I agree that asking the pref service every
time would be worse.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.