crash if I quit camino while a web page is still open.

RESOLVED WORKSFORME

Status

Camino Graveyard
General
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Richard Miller, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash})

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050914 Camino/1.0a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050914 Camino/1.0a1

Camino crashes if web page is still open when quiting the Camino application.

Reproducible: Sometimes

Steps to Reproduce:
1.leave current web page open
2.Choose quit camino from the Camino menu
3.

Actual Results:  
Camino crashed or froze requiring a force quit.


Expected Results:  
Quit normaly

Yahoo homepage or any web page.
(Assignee)

Comment 1

13 years ago
can you attach a stack trace from the console app? 

smfr, i wonder if this is the JS crasher that's already been fixed.

Comment 2

13 years ago
Yeah, most likely the know quit crasher.

Comment 3

13 years ago
The crash we're all alluding to here is in JS_DHashTableOperate, bug 307289. 
That crases with the 1.0a1 release but is fixed in the 1.0 branch morninglies.

Updated

13 years ago
Severity: normal → critical
Keywords: crash
Reporter, can you please attach a crashlog so we can confirm this is the bug we
think it is (or start investigating if it's not).

http://www.caminobrowser.org/support/sup_bugzilla.html for details on getting
the crashlog.

Comment 5

13 years ago
Don't know what version he's running. But I've noticed this behavior on 1.0a1,
where it seems to always crash on Quit.

Comment 6

13 years ago
Here's the scoreboard: days 10, feedback 0.  Since we've got a likely bug to
hang this on (bug 307289) and since that bug's been fixed, -> WFM.

Richard, if you ever resurface: if you notice this bug again with a branch
nightly or the next 1.0-series release, get a crash log or talkback ID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Comment 7

12 years ago
Created attachment 206508 [details]
Crash Report for crash when quitting Camino

Comment 8

12 years ago
this is a general shutdown ordering bug. bsmedberg has plans to fix that....
You need to log in before you can comment on or make changes to this bug.