Crash clicking on bookmark "More About What's Related"

VERIFIED DUPLICATE of bug 30557

Status

()

Core
XUL
P1
critical
VERIFIED DUPLICATE of bug 30557
18 years ago
18 years ago

People

(Reporter: scalkins, Assigned: Steve Lamm)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] w/b minus on 3/10)

(Reporter)

Description

18 years ago
Saw this on
Win32 and Linux  2000-03-03-07 M15
Mac 2000-03-07-08 M15

Steps to repro:
1)Launch Seamonkey.
2)When browser appears, click on the "What's Related" tab in Sidebar.
3)Scroll Down to the item "Learn More About What's Related" and double click on 
that bookmark in the sidebar.

Actual Results: You will crash.
Expected: No crash, and you get a web page explaining "What's related".
Notes: I see the crash with other bookmarks in What's related too, but 
concentrated on this one cause I could reproduce it every time with it, and it's 
probably the one customers will use a lot.
(Reporter)

Updated

18 years ago
Keywords: beta1
Priority: P3 → P1
(Reporter)

Comment 1

18 years ago
Talk back trace:
ncident ID 6462294 
 Trigger Time 
               2000-03-07 16:19:39 
 Email Address 
               scalkins@netscape.com 
 User Comments 
               WHATSRELATED crash in Win32 2000-03-07-09 M15 
 Build ID
               2000030709 
 Product ID
               Communicator5.0 
 Platform ID
               Win32 
 Stack Trace

nsTreeIndentationFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeIndentationFrame.cpp, 
line 107] 
nsBoxFrameInner::FlowChildAt 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 2292] 
nsBoxFrame::GetChildBoxInfo 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 922] 
nsBoxFrame::GetBoxInfo 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 2947] 
nsBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1148] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
nsTableCellFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp, line 
694] 
nsTreeCellFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeCellFrame.cpp, line 148] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
nsTableRowFrame::InitialReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
976] 
nsTableRowFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line 
1343] 
nsTreeRowFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeRowFrame.cpp, line 217] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
nsTableRowGroupFrame::ReflowMappedChildren 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 436] 
nsTableRowGroupFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 1095] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
nsTableRowGroupFrame::ReflowMappedChildren 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 436] 
nsTableRowGroupFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp, 
line 1095] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
nsTableFrame::ReflowMappedChildren 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2935] 
nsTableFrame::ResizeReflowPass2 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 1948] 
nsTableFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 1590] 
nsTreeFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeFrame.cpp, line 412] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
nsTableOuterFrame::IR_InnerTableReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
726] 
nsTableOuterFrame::IR_TargetIsInnerTableFrame 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
500] 
nsTableOuterFrame::IR_TargetIsChild 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
491] 
nsTableOuterFrame::IncrementalReflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
449] 
nsTableOuterFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line 
959] 
nsTreeOuterFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsTreeOuterFrame.cpp, line 138] 
nsBoxFrameInner::FlowChildAt 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 2292] 
nsBoxFrameInner::FlowChildren 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1479] 
nsBoxFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1206] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
RootFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 334] 
nsContainerFrame::ReflowChild 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 
661] 
ViewportFrame::Reflow 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 531] 
nsHTMLReflowCommand::Dispatch 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp, line 
145] 
PresShell::ProcessReflowCommands 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2077] 
ReflowEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1977] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 557] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, 
line 520] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
1013] 
USER32.dll + 0x1820 (0x77e71820) 

Comment 2

18 years ago
[PDT+] w/b minus on 3/10, cc evaughan
Whiteboard: [PDT+] w/b minus on 3/10

Comment 3

18 years ago
I've tried this multiple times on Windows and Linux and I just can't make this
happen.  Even clicking repeatedly like a fiend.  Can anyone else reproduce this?
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

18 years ago
I can duplicate this pretty much at will. You have to be certain to follow 
step#3 "Scroll Down to the item". Scrolling down line by line by clicking on the 
bottom arrow does not seem to cause the crash. You have to click below the tab 
to do a page down and then double-click on one of the entries.

So to duplicate:

1. Launch seamonkey and size browser window fairly small (the default size on a 
new profile will work).
2. Open What's Related tab. 
3. Click once (or twice if needed) on scroll bar below tab to scroll down one 
page.
4. Double Click on Learn More about What's Related.

You will then crash. However, I think this may be a duplicate of 30557, so 
cc:ing mr hyatt
Status: RESOLVED → REOPENED
Component: Sidebar → XP Toolkit/Widgets
QA Contact: paulmac → jrgm
Resolution: WORKSFORME → ---

Comment 5

18 years ago
Hmmmmm.  Steve, can you repro this?  And could this be a duplicate of bug #30557
(as squid supposes)?
Target Milestone: M14
(Assignee)

Comment 6

18 years ago
Looks like a duplicate to me. We will know soon enough, because hyatt has a fix.
I will add a comment to the other bug on steps to reproduce.

*** This bug has been marked as a duplicate of 30557 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Verified duplicate on 
   macos 8.6   2000030910 opt comm
   linux rh6.0 2000030913 opt comm
   win98       2000030909 opt comm
(and, the fix for bug 30557 would seem to have fixed the crash).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.