Last Comment Bug 309227 - nsEventStateManager needs to support mousewheel.withmetakey
: nsEventStateManager needs to support mousewheel.withmetakey
Status: RESOLVED FIXED
: fixed1.8
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: PowerPC Mac OS X
: P1 normal (vote)
: mozilla1.8beta5
Assigned To: Mano (::mano, needinfo? for any questions; not reading general bugmail)
: Hixie (not reading bugmail)
:
Mentors:
Depends on: 171680
Blocks: 309345 309730
  Show dependency treegraph
 
Reported: 2005-09-19 18:10 PDT by Mark Mentovai
Modified: 2005-09-26 17:04 PDT (History)
1 user (show)
mtschrep: blocking1.8b5+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.96 KB, patch)
2005-09-19 20:12 PDT, Mano (::mano, needinfo? for any questions; not reading general bugmail)
mark: review+
neil: superreview+
mtschrep: approval1.8b5+
Details | Diff | Splinter Review

Description Mark Mentovai 2005-09-19 18:10:50 PDT
Follow-up to bug 171680 comment 23:

Now that scrolling with modifier keys works properly on the Mac, there needs to
be a way to map command-scroll to something.  Currently, only shift, control,
and alt/option are mappable.  Meta/command needs to be added to the list.

The default action for command-scroll (vertical) should be history traversal. 
Shift-scroll is bound this way, but bug 171680 comment 23 says why that's not
reliable on the Mac.
Comment 1 Mark Mentovai 2005-09-19 18:13:00 PDT
This should block because it used to be possible to do history traversal with
the scroll wheel on the Mac in 1.0, and now it's not.
Comment 2 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-19 20:12:56 PDT
Created attachment 196737 [details] [diff] [review]
patch

I will pref the desired behavior in the app level, in another bug.
Comment 3 Mark Mentovai 2005-09-19 20:29:17 PDT
Comment on attachment 196737 [details] [diff] [review]
patch

Mmmkay.  r=me as long as all.js gets defaults for withmetakey when
HORIZSCROLL_AVAILABLE is not defined.
Comment 4 neil@parkwaycc.co.uk 2005-09-25 06:49:26 PDT
Comment on attachment 196737 [details] [diff] [review]
patch

I see this code missed the great AppendLiteral sweep :-/ File a bug please.
Comment 5 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-25 20:38:52 PDT
Checking in modules/libpref/src/init/all.js;
/cvsroot/mozilla/modules/libpref/src/init/all.js,v  <--  all.js
new revision: 3.599; previous revision: 3.598
done
Checking in content/events/src/nsEventStateManager.cpp;
/cvsroot/mozilla/content/events/src/nsEventStateManager.cpp,v  <-- 
nsEventStateManager.cpp
new revision: 1.614; previous revision: 1.613
done
Comment 6 Mike Schroepfer 2005-09-26 14:20:03 PDT
Comment on attachment 196737 [details] [diff] [review]
patch

Approved per 9/26 bug triage meeting.
Comment 7 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-26 17:04:30 PDT
1.8 branch:
Checking in modules/libpref/src/init/all.js;
/cvsroot/mozilla/modules/libpref/src/init/all.js,v  <--  all.js
new revision: 3.585.2.11; previous revision: 3.585.2.10
done
Checking in content/events/src/nsEventStateManager.cpp;
/cvsroot/mozilla/content/events/src/nsEventStateManager.cpp,v  <-- 
nsEventStateManager.cpp
new revision: 1.595.2.9; previous revision: 1.595.2.8
done

Note You need to log in before you can comment on or make changes to this bug.