Lost all the previous data/events. Even the newly entered events are not showing up

RESOLVED WORKSFORME

Status

Calendar
General
--
critical
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: karthik_tkn, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

Hi,
      I have mozill version 0.2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8a5) Gecko/20050203 Mozilla Sunbird/0.2).
      Yesterday, my laptop crashed and restarted by itself(I dont know why). I
had my calendar open when it crashed. After it boots up, I was not able to see
any of my events in the calender-it looks blank. Even if I type something
new(either task or event) it is not showing up. I restarted the computer,
restarted the calendar, no improvements. Is there any way to get my tasks/events
back?

Thanks!!!

Reproducible: Always

Comment 1

12 years ago
Your calendar file was likely truncated, resulting in an invalid .ics file. 
Something similar happens in bug 257175.  See especially the 5th comment there.
 You should open the .ics file in question in text editor and fix the truncation.
(Reporter)

Comment 2

12 years ago
There are no .ics file in my computer

Comment 3

12 years ago
(In reply to comment #2)
> There are no .ics file in my computer

There definitely should be.  Sunbird stores all of its data in .ics files. 
These can be found in your profile folder. http://kb.mozillazine.org/Profile#Sunbird

A typical Windows XP 'Find' search will not reveal them, because the
'Application Data' folder is hidden by default.

(Reporter)

Comment 4

12 years ago
Found the .ics file.  Removed unwanted stuff and inserted END:VCALENDAR. 
Now it works fine:)  I got all my events back.

Thanks
Karthik
(Reporter)

Comment 5

12 years ago
Found the .ics file.  Removed unwanted stuff and inserted END:VCALENDAR. 
Now it works fine:)  I got all my events back.

Thanks
Karthik
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
Sorry to be picky, but we don't mark bugs fixed unless they are solved by a
change in a particular area of the codebase.  The truncation issue has been
mostly fixed on trunk builds.  Therefore, this should be WORKSFORME.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.