must perform multiple updates if it's been more than 1 day on daily builds

RESOLVED DUPLICATE of bug 306864

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 306864
12 years ago
9 years ago

People

(Reporter: Brandon, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050919 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050919 Firefox/1.4

I was away for 3 days at the beginning of the week. On Wednesday I ran software
update, but that just caught me up to Monday. I then had to restart Firefox and
repeat the process until I got caught up to today.  

For daily's this is fine, but in production I would think end users would expect
to be able to catch up updates.  So for example if I was running 1.0.3 and
didn't use the computer for awhile and then wanted to update to 1.0.6.  I would
expect to do this in 1 software update not 3.  With the current setup I believe
I would get 1.0.4 after running update.

Reproducible: Always

Steps to Reproduce:
1. Use daily branch build
2. in about:config set app.update.url to
https://aus2.mozilla.org/update/1/%PRODUCT%/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/update.xml
3. Wait a few days
4. Do the update
Actual Results:  
build version only goes up 1 day.


Expected Results:  
I should be updated to the latest build.

Comment 1

12 years ago
Dupe of bug 306864. See also bug 284589.

*** This bug has been marked as a duplicate of 306864 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.