Attempting to open a abcnews.com url will cause a crash.

VERIFIED FIXED

Status

()

P1
critical
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: chrispetersen, Assigned: rickg)

Tracking

({top100})

Trunk
top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] w/b minus on 3/10, URL)

(Reporter)

Description

19 years ago
Build: Apprunner
Version: 2000030709
Platforms: All
Expected results: The abcnews.com url should load without crashing.
What I got: The browser crashs when attempting to load the specified url.

Steps to reproduce:

1) Open www.abcnews.com in apprunner.
2) On the left side of page, a list of links are displayed.
3) Click on the business link.
4) The url is referenced and crashes the brower.

* On Mac, Macsbug reports the following:
  
PowerPC illegal instruction at FFC10000 _CursorDeviceDispatch+014E0

* On Windows, I get a recieve the following error:

MOZILLA caused a invalid page fault in module GKPARSER.DLL.
(Reporter)

Updated

19 years ago
Priority: P3 → P1

Comment 1

19 years ago
*** Bug 30905 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
Crashes also on Linux build 2000.03.07.09. Marking top100, beta1.
Keywords: beta1, top100

Comment 3

19 years ago
[PDT+] w/b minus on 3/10
Whiteboard: [PDT+] w/b minus on 3/10
(Assignee)

Comment 4

19 years ago
Fixed and tested. All 50 (or so) of our residual style bug testcases passed 
without a hitch. The crash is also gone. Code has been reviewed, too. I'm 
running the precheckins now.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

19 years ago
Fixed by correction to residual style stack maniuplation. Nodes were being 
released() but not popped. This also fixes 30885.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
fixt on WinNT, Win98, Linux, & Mac
Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.