Removing cookies - "don't allow site to set cookies in the future" not working properly

RESOLVED DUPLICATE of bug 237795

Status

()

RESOLVED DUPLICATE of bug 237795
13 years ago
13 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)

In the 'view cookies' dialog, the state of the "don't allow removed sites to set
cookies in the future" checkbox is ignored when cookies are removed.  Instead
it's state applies to all removed cookies when the window is closed.  This means
you cannot remove some cookies temporarily and others permanently without
closing the preferences and returning.

Reproducible: Always

Steps to Reproduce:
1. Go to the view cookies dialogue
2. Uncheck the box
3. Select a cookie and remove it
4. Check the box
5. Select a cookie and remove it
6. Click OK
6. Look at the exceptions - both sites will be listed.  (Note, you have to close
the whole preferences box and go back into it to see your changes, as reported
in bug 237795).

Actual Results:  
All removed sites are either added to the exceptions list or not, depending on
the state of the checkbox when the window is closed.

Expected Results:  
Cookies that are removed when the check box is checked should appear in the
exceptions list, cookies that are removed when it is not checked should not.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050919
Firefox/1.6a1 ID:2005091922

The setting only takes place after a browser restart. 

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 237795 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
This is not a duplicate of bug 237795.  The bug reported there is that removed
cookies do not show up in the exceptions window until  the browser is restarted.
 In this bug, the cookie removal code does not properly obey the checkbox on the
View Cookies dialog.  The two are distinct (even if they may ultimately be
solved together).

I have reopened.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

13 years ago
Yes, but what this boils down to is that since instantApply isn't on by default
in Windows, the pref. isn't applied till you click OK. It's the same issue here.
And FWIW, all you have to do is click OK for the pref. to apply, you don't need
to restart. Also, this can all be remedied by setting
browser.preferences.instantApplyto true in about:config.

*** This bug has been marked as a duplicate of 237795 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

13 years ago
I will set that setting, and hopefully that will solve it for me, but this 
behaviour is extremely counter-intuitive.  Last month I spent half an hour 
going through hundreds of cookies and selecting which ones to permanently block 
and which ones to just remove, only to find out that for some reason I was 
unable to log into a few oft-visited sites.  I found out that ALL my cookies 
had for some reason been blocked regardless of the setting of that checkbox, so 
I then had to repeat the process in reverse.

In my opinion this is a definite bug, and one that I am sure will cause other 
people to similarly waste their time.  If you are sure it will be fixed when 
237795 is fixed then I am happy to leave it marked as a duplicate, but as far 
as I am concerned it is a separate and equally frustrating bug.  I will reopen 
if 237795 is fixed and this behaviour is still in effect.

Comment 6

13 years ago
I think the point here is that the 'unless I have removed cookies set by this
site' function makes more sense on the View Cookies menu, so you can adjust it
as delete cookies, rather than being on the previous menu.  This would then
remove any need to know instantApply.

As the only actions that are dependant on 'unless I have removed cookies set by
this site' are on the View Cookies menu, and not on the panel it currently sits
on - it would seem to make more sense.  

If on the View Cookies panel, it could act immediately like other options tick
boxes - 

o In Content: 'Allowed Sites' for Block Popup Windows
o In Content: 'Allowed Sites' for Allow Web site to install software
o In Content: The 'advanced' button for Javascript in Content
o In Tabs:    Force links that open New Windows in
o In Downloads: Show download manager when downloads begin

(List from 310613#2)

I guess the coding is different, but from a user perspective the expected
behaviour is the same.

Comment 7

13 years ago
(In reply to comment #6)

Final thought, why not have 3 buttons on View Cookies:-

1. Remove Cookie
2. Remove Cookie and Block Site
3. Remove all Cookies

Button 2 has the function currently assigned to 'unless I have remove cookies
set by the site' 

This also highlights that 'Remove all Cookies' won't block them. You would need
to select all and click 2. 

This way you avoid the problem that will occur when 237795 is fixed, in that
when you clean up your cookies and wish to block some and just delete others,
you don't have to figure out that you need to flip out to the previous menu,
change the tickbox and return to achieve this.
(Reporter)

Comment 8

13 years ago
(In reply to comment #7)

That is a good proposal.  Clear and unambiguous.
You need to log in before you can comment on or make changes to this bug.