If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Once the download exceed 2Gig the Amount downloaded overflow and displays a negative value

VERIFIED DUPLICATE of bug 228968

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 228968
12 years ago
9 years ago

People

(Reporter: Mark, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Large download are causing the amount downloaded to display negative values.
This also affects the download speed counter (which also goes negative). This
occurs around the 2 Gig Figure and above. (You can doo the binary sums)

Reproducible: Always

Steps to Reproduce:
1. Choose a very large file
2. download and view the manager
3. after around 1.6G+ the display will go negative



Expected Results:  
You need to use a LARGER storage type (eg. Double) OR change the display to Meg
bytes when it is very large.
(Reporter)

Comment 1

12 years ago
Created attachment 196791 [details]
Download manager info

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.0 Branch
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.