Upgrading OS from Windows 98 to Windows 2000 causes loss of profile data

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: dvd_id10t, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: H'n'C)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.11) Gecko/20050728
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.11) Gecko/20050728

I upgraded from Windows 98 SE to Windows 2000, and when I started Mozilla after
the OS upgrade, none of my profiles were accessible anymore.  I did find the old
profile data in the same directory it was before I upgraded OSes, but the
profile was not choosable in the profile UI.

Reproducible: Always

Steps to Reproduce:
1. Install Windows 98 Second Edition (probably fails similarly in the "Original"
Win 98)
2. Install and Use Mozilla normally, building up profile data and password
manager list.
3. Upgrade OS to Windows 2000.

Actual Results:  
The profile I was using seemed to be missing, something about "profile directory
could not be found".

Expected Results:  
Should have somehow determined that the OS had been upgraded, and either moved
the old profile information, or used the old directory structure.
(Reporter)

Comment 1

13 years ago
I may have reinstalled Mozilla after step 3, as well, but I'm not certain of that.
Like other applications profile data, moz profiles are stored in different
places in win98 and win2000. See http://kb.mozillazine.org/Profile_folder

Actually, I'd have expected the OS upgrade process move that data for you. But
since it didn't you can easily do it yourself, and the data should be there. 
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Like other applications profile data, moz profiles are stored in different
> places in win98 and win2000. See http://kb.mozillazine.org/Profile_folder
> 
> Actually, I'd have expected the OS upgrade process move that data for you. But
> since it didn't you can easily do it yourself, and the data should be there. 

Somehow my original <numbers>.s file got renamed, and I eventually figured out
which of the many locations my Profile data was stored in.  It's in 3 or 4
folders, in various locations all over the disk, both Windows 98 locations, and
Windows 2000 locations.  I finally managed to figure out which one was actually
in use, and copied the old .s file to the current .s file name found in
prefs.js.  My password list seems to be back, but I'm not sure I've gotten the
Bookmarks back.  This will take more work.
Resolving INVALID due to lack of a more suiteable option. There's not really a way to reproduce this issue - which should go away just by waiting a little bit longer anyway ;->
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Whiteboard: H'n'C
You need to log in before you can comment on or make changes to this bug.