Opening many tabs at once halts if one URL's connection is refused

RESOLVED DUPLICATE of bug 74331

Status

()

defect
--
minor
RESOLVED DUPLICATE of bug 74331
14 years ago
10 years ago

People

(Reporter: tempshill, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6 (ax)

In the "Bookmarks" menu, I have a submenu called "Typical web pages" which
contains 16 bookmarks, and every morning I choose "Open in Tabs" at the bottom
of that submenu in order to open all 16 web pages, each in its own tab.

One of the bookmarks points to "192.168.1.101" on my local network.  (Actually,
the exact URL is "http://192.168.1.101/wiki/index.php/Main_Page".)  When I
choose "Open in Tabs" while that computer doesn't exist or is off, Firefox
creates the 16 tabs and starts loading them, but after a couple of seconds it
stops loading all the tabs and displays a dialog saying "The connection was
refused when attempting to contact 192.168.1.101."  None of the tabs continues
to load while this dialog is being displayed.

It would be preferable if the other tabs would continue to load in the
background while this dialog is being displayed.


Reproducible: Always

Steps to Reproduce:
1. Create a submenu in the "Bookmarks" menu that includes 16 URLs, including one
that points to a numeric IP address that doesn't exist.
2. Choose "Open in Tabs" from that submenu.
3. Observe.


Actual Results:  
A dialog box appears saying "The connection was refused when attempting to
contact 192.168.1.101."  As soon as this dialog box appears, all the other tabs
stop loading in the background.

Expected Results:  
The other tabs should continue loading in the background.

The computer at 192.168.1.101 didn't exist in these cases because it gets its IP
address via DHCP and got assigned a different IP address.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050920
Firefox/1.4 ID:2005092009

WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050920
Firefox/1.6a1 ID:2005092008

WFM in the latest builds.
I see this happen in 1.0.6 indeed, but only with browser.xul.error_pages.enabled
to false (default).

Comment 3

14 years ago
1.7 branch has problems with modal dialogs and networking, could be bug 74331.
Version: unspecified → 1.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 74331
You need to log in before you can comment on or make changes to this bug.