If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

onScroll event doesn't fire for most situations

RESOLVED DUPLICATE of bug 189308

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 189308
12 years ago
12 years ago

People

(Reporter: David Schontzler, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When you attempt to listen on the window or document object's onScroll event,
the event is only fired if the user scrolls by clicking in the scrollbar
(arrows, dragging the scrollbar, clicking between arrow and bar). Events are
*not fired* in the following situations:
- page up/down
- arrow up/down left/right
- home/end
- scrollwheel

Reproducible: Always

Steps to Reproduce:
1. Create a page with lots o' content and an onscroll listener that alerts (or
notifies you somehow)
2. Scroll as many ways as you know how.
3. Notice that you only get the event fired when you are playing with the
scrollbar directly.



Expected Results:  
You'd expect the event to be fired whenever you scroll a page regardless of the
means of scrolling. I think that firing the event on scrollwheel movement is
especially critical as it seems to be the way that folks use to scroll through
content these days.
Please test with a nightly trunk build. This should be fixed in current trunk
builds:
http://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-trunk/

Comment 2

12 years ago
You're using an old release. 
"be sure that you've reproduced your bug using a build released within the past
three days. Our development process moves at lightning speed, and the bug you've
found may already have been fixed."
http://www.mozilla.org/quality/bug-writing-guidelines.html

The bug description you give fits exactly bug 189308.

*** This bug has been marked as a duplicate of 189308 ***

*** This bug has been marked as a duplicate of 189308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.