Closed Bug 309371 Opened 17 years ago Closed 14 years ago

unable to set hints_and_tips.url in any preferences since 20050907

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b1

People

(Reporter: bugzilla, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file, 3 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050919 Firefox/1.4
Build Identifier: Thunderbird version 1.5 Beta 1 (20050920) and 1.6a1 (20050920)

It's not possible to set the throbber.url's anymore. They're probably hardcoded
or using the values from the language.jar-files.

I did a bonsai and found bug 307290 changing something with the throbbers, but
I'm not sure if that's the one - or if it's a new feature/setting?

Reproducible: Always

Steps to Reproduce:
1. Change any of the throbber.url's
2. Click a throbber - you can restart after changing settings, if you wish.
Actual Results:  
You'll end up at http://www.mozilla.org/products/thunderbird/ eventhough the
address is http://foo.bar

Expected Results:  
You should end up at http://foo.bar

As reported by Valik in the forums:
http://forums.mozillazine.org/viewtopic.php?t=320109
Confirming
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20050920 Thunderbird/1.4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
the throbber url can be changed by localizers in:

http://lxr.mozilla.org/mozilla/source/mail/locales/en-US/chrome/messenger-region/region.properties#7

same spot it's always been. Or maybe I'm misunderstanding something. 
Correct - it has always been there for localizers, but it has also been possible
to change the settings in the prefs.

If you goto Tools > Options > Advanced > Config Editor - enter "throbber" as
filter, and change all the values to something different, then you won't get to
other addresses than Thunderbird's product site.

This was possible to change in earlier versions.
Attached patch proposed fix (obsolete) — Splinter Review
This makes the "messenger.throbber.url" work. For the other throbber urls
changes doesn't seem to take effect.
Attachment #198723 - Flags: review?(mscott)
Attached patch proposed fix, v2 (obsolete) — Splinter Review
Realized tb uses messanger.throbber.url for all the throbbers... So this should
be ok.
Attachment #198723 - Attachment is obsolete: true
Attachment #199188 - Flags: review?(mscott)
Attachment #198723 - Flags: review?(mscott)
Comment on attachment 199188 [details] [diff] [review]
proposed fix, v2

Scott, can we get this in for 1.5rc1?
Flags: blocking1.8rc1?
sorry it's too late for this. We're already passed the lock down.
Flags: blocking1.8rc1? → blocking1.8rc1-
Problem continues in Thunderbird 1.5 (20051201). Will there be happiness sometime soon?

I cannot change it either in user.js or in Tools-->Options-->etc.-->Config Editor.
*** Bug 326434 has been marked as a duplicate of this bug. ***
Summary: Unable to set throbber.url in any preferences since 20050907 → Unable to set throbber.url/hints_and_tips.url etc in any preferences since 20050907
Whiteboard: [patch awaiting review]
It's a major regression for us because we can't deploy thunderbird 1.5 without
french user help capability.
We must deploy TB15 in end of 2006Q2 over 80.000 PC.

We don't want to recompile source code to fix this issue because we don't have the knowledge to do this. 

Some hundreds PCs were already configured with a TB10 which has a modifyed url for help in the prefs.js. So we can't say to these users "sorry, there's no more french help in TB1.5"

TB15 is very important for us because We plan to use autoconfig capability. And autoconfig only modify the prefs.js.

A solution is required urgently !

Thanks
Scott: review ping? Seems this affects some large deployments.
(In reply to comment #2)
> the throbber url can be changed by localizers in:
>http://lxr.mozilla.org/mozilla/source/mail/locales/en-US/chrome/messenger-region/region.properties#7

A workaround to this issue based on this URL : 

 1. Go C:\Program files\Mozilla Thunderbird\chrome
 2. Rename fr.jar to fr.jar.zip (I talk about french TB but each localization
    has its own file)
 3. Extract all files in a new directory
 4. Edit the text file ./locale/fr/messenger-region
 5. Change URL key values and save.
 6. Rebuild the archive file with the original directory hierarchy
 7. Rename archive to fr.jar
 8. Replace original fr.jar with the new one.

Then, a click on a throbber or on the help item in the help menu will now aim your web server.

So, it's just a workaround. If the prefs keys aren't back before the end of 2006Q2, we'll have to do a special package for our deployment. But we don't enjoy this perspective.

Thanks to the developpers to fix the issue or to explain the reason of this change. 

I do confirm that this issue has an impact on large deployments, in my case possibly several ten thousand computers...
Comment on attachment 199188 [details] [diff] [review]
proposed fix, v2

Scott, review ping?
Any word on getting this fixed? I tried setting a new string in about:config, but it had no effect.
*** Bug 354061 has been marked as a duplicate of this bug. ***
Revision to comment #2 for Thunderbird 1.5.0.8 (US):
A workaround to this issue based on this URL : 

 1. Go C:\Program files\Mozilla Thunderbird\chrome
 2. After creating a backup copy, rename en-US.jar to en-US.jar.zip
 3. Extract all files in a new directory
 4. Edit the text file ./locale/en-US/messenger-region/region-properties
 5. Change URL key values and save
 6. Rebuild the archive file with the original directory hierarchy (zip up the "locale" directory and its contents)
 7. Rename archive to en-US.jar (normal compression works fine)
 8. Replace original en-US.jar with the new one.
Throbber is not clickable anymore (bug 347499), updating summary. You should still be able to set the help url as a pref.
Summary: Unable to set throbber.url/hints_and_tips.url etc in any preferences since 20050907 → unable to set hints_and_tips.url in any preferences since 20050907
Attached patch proposed fix, v3 (obsolete) — Splinter Review
Scott, how about this? If reads the help url as a pref.
Attachment #199188 - Attachment is obsolete: true
Attachment #245597 - Flags: review?(mscott)
Attachment #199188 - Flags: review?(mscott)
Throbber still works for me just fine, as far as clickable-ability is concerened. I even have it point to my spamcop heldlog webpage pursuant to the workaround.
Blocks: 363234
Throbber no longer works in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3; will search for relevant bug or report one if none found.
See comment 18... it's intended.
If Scott not interested, perhaps needs different reviewer?
Assignee: mscott → nobody
Magnus: Should we kill this bug (WONTFIX) ?

It's been so long and I think there is an extension, which brings the function back. Otherwise people can just mess around in ab-CD.jar files.
Mark, Bryan - see comment 13, 19, etc 
wanted? or wontfix?
Whiteboard: [patch awaiting review] → [patchlove]
Comment on attachment 245597 [details] [diff] [review]
proposed fix, v3

mscott no longer actively reviewing, so canceling review
Attachment #245597 - Flags: review?(mscott)
I think this will probably be wontfix, or at least different after bug 450038.
The feature has been gone for such a long time, so I don't care about it anymore.

So it's ok to wontfix, if you ask me.
(In reply to comment #28)
> The feature has been gone for such a long time, so I don't care about it
> anymore.
> 
> So it's ok to wontfix, if you ask me.

If no other demand for this ...
Depends on: 450038
(In reply to comment #29)
> (In reply to comment #28)
> > The feature has been gone for such a long time, so I don't care about it
> > anymore.
> > 
> > So it's ok to wontfix, if you ask me.
> 
> If no other demand for this ...

A two years old workaround is always a workaround nowadays. A workaround is useful in its time but it makes the administration more complex and weakens the deployed product. It is more interesting to have keys which can be locked via the autoconfig(mcd). 

Beyond the key itself, the real topic is how to manage Thunderbird (or Firefox) in corporate area and there is a newsgroup to discuss it. (mozilla.community.enterprise) 

Thus I think this issue deserves to be solved.
perhaps the discussion in .enterprise could include ideas of using start page or help menu via prefs or extension, which I would think are far more discoverable.
Attached patch proposed fix, v4Splinter Review
Actually, let's use this bug to clean up the opening url, it also actually fixes this bug (by moving the pref to a all-thunderbird.js). The *formatted* pref now lives in region.properties, which makes no sense. 

Also, use the same pref name as firefox, and start using loadURI instead of the deprecated loadUrl which might be going away at some point (bug 389565).
Assignee: nobody → mkmelin+mozilla
Attachment #245597 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #341741 - Flags: review?(bugzilla)
Hardware: PC → All
Whiteboard: [patchlove]
Target Milestone: --- → Thunderbird 3.0b1
Attachment #341741 - Flags: review?(bugzilla) → review+
Comment on attachment 341741 [details] [diff] [review]
proposed fix, v4

>diff --git a/mail/app/profile/all-thunderbird.js b/mail/app/profile/all-thunderbird.js
>--- a/mail/app/profile/all-thunderbird.js
>+++ b/mail/app/profile/all-thunderbird.js
...
> // The breakpad report server to link to in about:crashes
> pref("breakpad.reportURL", "http://crash-stats.mozilla.com/report/index/");
>+
>+// Base URL for web-based support pages.
>+pref("app.support.baseURL", "http://support.live.mozillamessaging.com/%LOCALE%/%APP%/%APPBUILDID%/");

nit: I think this should go next to the app.releaseNotesURL

>-/**
>- * Opens the support page based on the 'mailnews_support_url' string in
>- * region.properties.
>- */
>+/** Opens the support page based on the app.support.baseURL pref. */

nit: please use the double-slash for this comment.

>+    var formatter = Components.classes["@mozilla.org/toolkit/URLFormatterService;1"]
>+                              .getService(Components.interfaces.nsIURLFormatter);
>+    var startpage = formatter.formatURLPref(startPageUrlPref());
>+

nit: I think you could drop the intermediate variable like you did in openFormattedURL.

r=me with those fixed.
(In reply to comment #33)
> >+/** Opens the support page based on the app.support.baseURL pref. */
> 
> nit: please use the double-slash for this comment.

Why? If i it's not possible to generate javadoc/doxygen documentation for it.
Er: "If I do, ..."
(In reply to comment #34)
> (In reply to comment #33)
> > >+/** Opens the support page based on the app.support.baseURL pref. */
> > 
> > nit: please use the double-slash for this comment.
> 
> Why? If i it's not possible to generate javadoc/doxygen documentation for it.

Generally because its ugly. Anyway, doxygen does support /// so please use that instead.
Nits fixed (and using a three row /** */ instead as decided over irc).

changeset:   605:b8b089ff063e
http://hg.mozilla.org/comm-central/rev/b8b089ff063e

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.