Very slow scrolling and strange flicker artifacts during scrolling

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
4 months ago

People

(Reporter: ceisserer, Assigned: roc)

Tracking

(Blocks: 1 bug, {perf})

Trunk
x86
Linux
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Scrolling the content of the Iframe is extremly slow on older systems plus
strange flicker artifacts occur during scrolling the iframe-content.

Reproducible: Always

Steps to Reproduce:
1. Open the url in FireFox: http://www.rekallrevealed.org
2. Click in the navigation tree (left) on RekallWeb, the tree opens 
3. now click on "Overview"
4. In the content-iframe the content opens, scroll this arround

Actual Results:  
Scrolling the content of the IFrame is very slow, it does not matter wether I
use wheel or scroll bars. Furthermore I can see strange flicker artifacts, in
the IFrame about 2cm right.

Note I use Linux and I think this could be related to the GTK2 port of FireFox
so the same results maybe do not happen on Windows.

I use a Duron-800 with a (accerlated X-Server installed) NVidia Geforce FX5200
and the system has 512mb PC100 SDRAM. I know a slow system but FF should be able
to handle scrolling this simple text (note: no images or anything else - text
only) withought feeling sluggish soo much.

Expected Results:  
Scrolling should work fluently.
I see this too with current trunk windows build.
There is a div with id="id000054" that has style="position: absolute; top: 0px;
left: 0px; visibility: hidden;"

That seems to cause the flicker artifacts when scrolling the overflow:auto div.

Anyway, I think this is a known bug, so this is very likely a duplicate.
Assignee: nobody → roc
Component: General → Layout: View Rendering
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk
(Reporter)

Comment 2

13 years ago
sorry that I reported a bug that's already known.
I know it causes tons of work reading and verifying all those bug-reports, you're doing a great job 
- thanks! Sorry that it was not useful after all.

Is the slow scrolling performance also related to this?
(Also saw slow scrolling on www.singles.at - seems to be related with the Adwords banner which 
seems to lag behind when scrolling)

lg Clemens
(In reply to comment #2)
> sorry that I reported a bug that's already known.
No need to apologise. These things happen all the time.

> Is the slow scrolling performance also related to this?
This is one of the  reasons for slow scrolling performance.

> (Also saw slow scrolling on www.singles.at - seems to be related with the
Adwords banner which 
> seems to lag behind when scrolling)
Yes, very likely also a known bug (although I don't see any slow scrolling there).

Comment 4

13 years ago
Thanks for a thorough bug report!

I'm not seeing this on MacOS X with FX 1.5b1. OTOH i'm having problems with the
scrollbar disappering and returning... :-/

(In reply to comment #2)
> sorry that I reported a bug that's already known.

Not that easy to find. Bug 100951 is a metabug for slow scrolling bugs, but I
didn't see anything obvious in that list. The artifact issue might or might not
be in that list.

Anyway, most of these bugs will have to be revisited (and hopefully closed :)
once the reflow branch lands. 
(In reply to comment #4)
> I'm not seeing this on MacOS X with FX 1.5b1. OTOH i'm having problems with the
> scrollbar disappering and returning... :-/
Please file a new bug for that, if you're seeing that in the latest nightly
trunk build and no bug has been reported for that.

This bug is WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

13 years ago
no I wont since I am absolutly not interrested in getting this bug fixed.

I tried it with FireFox-1.5b1/Linux/GTK2 and and FF-1.0.6 on the same platform
and that I could be helpful in telling the mozilla project that something is
wrong. As I said I tried it on 1.5b1 and since the bug looks performance related
it could be that this happens only on Linux.
Others were able to reproduce it too, so well I have proven its a bug and it
exists in 1.5b1/Linux and another reported that it exists on WIndows too. If it
does not exist in MAc, well great luck!

If the mozilla project is not seriously trying to track this problem down its
not my problem - and I am not willed to do the usual "nerv as long as at least a
single developer trusts that something is wrong".
The same happens with eclipse too: I report a bug, a few devs read over and say
its no bug, I say they should try -> its a bug *wow*. Now they say they will fix
it and now tons of unresolved bugs are hanging arround.

Sorry, I am not developer's toy
sorry, made a mistake here. I really can't say anything about Linux bugs.
I'm not really seeing slow scrolling on Windows, only the artifacts while
scrolling, but that's a known bug.
the slow scrolling issue might also be a known bug, though.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Profile says most of the time is spent under the following:

              50432 _XRead
              45057 _XError
              44131 g_main_context_check
              17643 _XSend

where the total hit count is:

Total hit count: 198230

This is with smooth-scrolling on, I believe.
Blocks: 100951
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9a1?
Keywords: perf

Updated

12 years ago
Flags: blocking1.9a1? → blocking1.9-

Comment 9

12 years ago
Retested, and this WFM on two systems - a very old slow machine /and/ a new fast one (with different, but recent, versions of Firefox.) The example page DHTML nav-tree still seems to be as described, and the example page says "tested against Konquerer 3.2.1, Firefox 1.0, IE 6" -- so, presumably has not been updated or changed recently.

Machine 1:
Intel PII, 233MHz, 320Mb RAM, almost ten years old, running Linux:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a3pre) Gecko/20070312 Minefield/3.0a3pre


Machine 2:
Intel Core2 T5600, 1.83GHz, 1Gb RAM, 3 months old, running Linux:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2) Gecko/20070220 Firefox/2.0.0.2

As with comment #8, SmoothScroll is on one both machines.


WFM per comment 9 and reporter, don't see on "my Laptop, but this system is far more powerful than my old Duron (Core2Duo-2x2ghz)."
Status: NEW → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → WORKSFORME
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.