Disabled extensions are re-enabled after automatic update

RESOLVED DUPLICATE of bug 299496

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 299496
13 years ago
13 years ago

People

(Reporter: db, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

After running the automatic update extensions that I had previously disabled
where re-enabled without notice.

Reproducible: Always

Steps to Reproduce:
1. Disable an extension A
2. Let TB update A automatically
3. Without noticing the user A is enabled after the update

Actual Results:  
A was enabled

Expected Results:  
Extensions should remain in the state they where prior to the update.

Another acceptable solution would be to only check enabled extensions for
updates. However, this is not an ideal solution because you might disable
extensions if they are, for example, unstable. In these cases you probably want
to be notified when an update is available.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 299496 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.