[RFE] Install Distribution Package with extension modules declaration

RESOLVED WONTFIX

Status

()

Toolkit
Add-ons Manager
P5
enhancement
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: pzavolinsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Actually this RFE is a two-in-one request.

First, it would be nice to be able to download an "extension-description" file
(EDF) instead of the real extension (.xpi). This EDF should hold a list of
mirrors pointing at the last release of the extension (of course with fault
tolerance because servers or internet connection may be down). Right now this
feature is possible by installing an old version of the extension and then
forcing a Software Update "Check Now". The idea behind this is to skip the old
soft installation and directly download the latest version.

Second, the installation file should search for an EDF-list file during install
and queue those extensions for download (maybe ask the user if he wants to
download the extensions now or do it at a later time).

As an example:
---ext.edf---
http://www.some-extension-devel-url.org/release/ext.xpi
ftp://mirror.sedu.org/firefox/extensions/ext.xpi

---EDF-List-File---
extensions/ext.edf
extensions/tidy.edf

Install dir image
-----------------
+-firefox-installer (executable)
+-extensions.edl    (extension description files list)
+-extensions/       (directory)
      +-ext.edf     (extension description file: "ext" extension)
      +-tidy.edf    (extension description file: "tidy" extension)

Reproducible: Always

Steps to Reproduce:
Ship firefox-installer and all the extensions' .xpi files.
1. Install firefox
2. Install every .xpi wanted
3. Force a Software Update "Check Now"

Actual Results:  
Hey, this is a RFE, but I don't like empty fields. The whole idea behind the RFE
is to avoid user interaction during the installation. This shouldn't be too hard
since it already can be done manually.

Expected Results:  
An "Always click 'next'" install program that ends up with a fully functional
firefox with all the extensions up and running.

Feel free to mail me for any additional explanations.

BTW: this RFE applys for every program that supports extensions so firefox here
is just an example.

Comment 1

13 years ago
This is not a Firefox request--it should be core, for all Mozilla applications that use extensions. Someone should change the product to "Core".

Comment 2

13 years ago
This RFE applies to the toolkit apps, but we use the "Firefox -> Extension Manager" component to track.
Component: Installer → Extension/Theme Manager
Priority: -- → P5
QA Contact: installer → extension.manager

Comment 3

13 years ago
(In reply to comment #2)
> This RFE applies to the toolkit apps, but we use the "Firefox -> Extension
> Manager" component to track.
> 

Thanks for the clarification.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
I believe that adding this to the extension manager is overkill. Websites can handle their own mirroring system using load-balancing or redirects in the same way that addons.mozilla.org does already. For the installation part that is really a separate issue for the installer, but it is already possible to use the CCK to ship a default set of extensions for the application.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.