In designMode, there is no way to delete tables

RESOLVED DUPLICATE of bug 236106

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 236106
12 years ago
12 years ago

People

(Reporter: FredCK, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

The related URL demonstrate that there is no way to delete tables while using 
Firefox for editing (designMode="on").

Reproducible: Always

Steps to Reproduce:
1. Navigate the URL: http://fredck.com/bugs/firefox/deletetable.html
2. Try to delete the table using the keyboard (<DEL> or <BACKSPACE>).
Actual Results:  
There is no way to delete it.

Expected Results:  
You should be able to delete the table when:

    * Select the table and hit <DEL> or <BACKSPACE> (actually, there is no way 
to select the table).
    * Place the cursor before the table and hit <DEL>.
    * Place the cursor after the table and hit <BACKSPACE>.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050921
Firefox/1.4 ID:2005092107

Confirmed
Not with Delete or Backspace but I've never seen that it was possible to delete
a table that way. A few clicks inside the table removes it.
(Reporter)

Comment 3

12 years ago
This is a usability issue. It natural to every user to use DEL and BACKSPACE to 
delete things. This is the way almost all HTML editor work, like Dreamweaver, 
Visual Studio, Word, etc... The IE implementation of designMode works in that 
way too.

I've noticed that it is possible to delete the table if you go deleting one 
column or row each time... but it is not so obvious, and could be a real 
trouble if you have large tables.

Anyway... it should just be intuitive to the user, without having to guess the 
way to do that.

Comment 4

12 years ago
I did already confirmed an older bug in core->editor, so dupping this one.

*** This bug has been marked as a duplicate of 236106 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.