page doesn't resize after resizing an iframe with javascript

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
13 years ago
8 years ago

People

(Reporter: Michael Dichtl, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

wenn i resize a iframe with javascript, de main-page doesn't resize too. i have
to  reload the page to solve this problem.
when i say, that de page doesn't resize, i mean:
e.g.
(1) the iframe has a height=1000px and the page is displayed correctly
(2) with javasript i resize the iframe to a height=500px
    and below the iframe, a empty place off 500px is displayed

note: on my site mentioned to demonstrade the bug, de tables reach the bottom of
the page. this is because i have given them a hight of 100% with css.
if you want, i can change the site temporaly to show you the problem. only send
me an email and i will do the changes as soon as possible.

---------------------
i'm sorry about my bad english - i'm an austrian boy

Reproducible: Always

Steps to Reproduce:
1.the iframe has a height=1000px and the page is displayed correctly
2.with javasript i resize the iframe to a height=500px
    and below the iframe, a empty place off 500px is displayed

Actual Results:  
...a empty place off 500px is displayed

Expected Results:  
should resize the page so that there isn't the empty space
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
Version: unspecified → 1.0 Branch
No reply, INCOMPLETE. Please retest with Firefox 3.6.3 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.