Smiley ;-) not displayed at all - theme missing file

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: BenB, Unassigned)

Tracking

({dataloss, regression})

Firefox Tracking Flags

(Not tracked)

Details

Reproduction:
1. Send a mail with the following line to yourself as plaintext:
   Get over it ;-).
2. Open it.

Actual result:
Get over it     .

Expected result:
Get over it (smiley image).
or at least:
Get over it ;-).

Severity:
This is data loss, because the existance of a smiley can substantially change
the tone and thus meaning of a message.

Analysis:
Theme is probably missing "wink" smiley image (class="moz-smiley-s3").
Firefox 1.5 Beta 1 on Mac, FWIW. I don't think I saw this in 1.0.6.
Severity: major → normal
Keywords: regression
This is on Windows as well and on trunk.
OS: MacOS X → All
Hardware: Macintosh → All
Sorry. This is unrelated to a very similar bug on Windows.
OS: All → MacOS X
Hardware: All → Macintosh
QA Contact: front-end
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.16) Gecko/20080707 Thunderbird/2.0.0.16 Mnenhy/0.7.5.666 ID:2008070710

I cannot reproduce the problem for display in plain text with display emoticons enabled. 

There is a smiley for
  Get over it ;-).

but no smileys for

  Get over it ;-)..
  Get over it ;-)). 
note: no data loss.

Assignee: mscott → nobody
Is this now WFM on Mac?
Yeah.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.