Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Too long string in file not found xul error page isn't wrapped

VERIFIED FIXED in mozilla1.9alpha1

Status

()

Core
Document Navigation
--
trivial
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: DooShan, Assigned: whimboo)

Tracking

({fixed1.8})

Trunk
mozilla1.9alpha1
fixed1.8
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050910 MultiZilla/1.8.0.1h SeaMonkey/1.0a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050910 MultiZilla/1.8.0.1h SeaMonkey/1.0a

When there appears a message that a file wasn't found and the path to the file
is too long, the string isn't wrapped and goes way off the table that shows this
message. It's not a big deal, it just doesn't look nice. The table was displayed
in seamonkey mailnews when my antivirus has deleted a message that contained a
virus.
Here's an image of that bug: <a
href="http://img292.imageshack.us/img292/2536/fnfbug1xf.gif"> fnfbug </a>

Reproducible: Always

Actual Results:  
the table showed a long path that wasn't wrapped


Expected Results:  
the path string should be wrapped
(Reporter)

Updated

12 years ago
Version: unspecified → Other Branch

Comment 1

12 years ago
This happens only when a local file (on a windows partition) isn't found:
file://c:/ABCDEFG010ABCDEFG020ABCDEFG030ABCDEFG040ABCDEFG050ABCDEFG060ABCDEFG070ABCDEFG080ABCDEFG090ABCDEFG100

http://www.nomozilla.org/ABCDEFG010ABCDEFG020ABCDEFG030ABCDEFG040ABCDEFG050ABCDEFG060ABCDEFG070ABCDEFG080ABCDEFG090ABCDEFG100
gives the same message without the long string, telling only: 
www.nomozilla.org could not be found. Please check the name and try again.

http://www.mozilla.org/ABCDEFG010ABCDEFG020ABCDEFG030ABCDEFG040ABCDEFG050ABCDEFG060ABCDEFG070ABCDEFG080ABCDEFG090ABCDEFG100
gives mozilla.org's custom 404 page.

(Reporter)

Comment 2

12 years ago
Hmmm, don't try to do that (copying an infected email to your local folder) in
your live mailbox or you will lose all your emails. The antivirus will delete
the whole file where the emails are stored and if you have other emails there,
it will delete them as well :).

Updated

12 years ago
Assignee: general → adamlock
Component: General → Embedding: Docshell
Product: Mozilla Application Suite → Core
QA Contact: general → adamlock
Summary: Too long string in file not found page isn't wrapped and goes way off the page → Too long string in file not found xul error page isn't wrapped
Version: Other Branch → Trunk
Confirmed with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050920
Firefox/1.6a1

The following location shows the same behavior:
file:///home/asdfjasdlfjlsadflsadjflasdflasdhflsfsdfsdfsdfsdfsfaw4rwerwrwwerwerwerwe345234234234234

We should use 'overflow: auto' for '#errorShortDesc > p' to prevent text
overflowing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Depends on: 280190
Created attachment 197071 [details] [diff] [review]
Patch for SeaMonkey
Assignee: adamlock → hskupin
Status: NEW → ASSIGNED
Attachment #197071 - Flags: review?(neil.parkwaycc.co.uk)
Created attachment 197072 [details] [diff] [review]
Patch for Toolkit
Attachment #197072 - Flags: review?(mconners)
Attachment #197072 - Flags: review?(mconners) → review?(mconnor)

Comment 6

12 years ago
*** Bug 309407 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
Comment on attachment 197071 [details] [diff] [review]
Patch for SeaMonkey

r+sr=me if mconnor's happy with attachment 197072 [details] [diff] [review].
Attachment #197071 - Flags: review?(neil.parkwaycc.co.uk) → review+
Flags: blocking1.8b5?

Updated

12 years ago
Attachment #197072 - Flags: review?(mconnor) → review+
Whiteboard: [checkin needed]

Updated

12 years ago
Attachment #197072 - Flags: approval1.8b5+
Attachment #197071 - Flags: approval1.8b5?

Updated

12 years ago
Flags: blocking1.8b5? → blocking1.8b5+

Comment 8

12 years ago
this checkin needs to happen ASAP if this is going to get in for 1.8. Do you
need a check in buddy Henrik?

Updated

12 years ago
Attachment #197071 - Flags: approval1.8b5? → approval1.8b5+
Trunk:
mozilla/toolkit/themes/winstripe/global/netError.css; new revision: 1.3;
mozilla/toolkit/themes/pinstripe/global/netError.css; new revision: 1.3;
mozilla/themes/classic/global/netError.css; new revision: 1.3;
mozilla/themes/modern/global/netError.css; new revision: 1.3;

1.8 Branch:
mozilla/toolkit/themes/winstripe/global/netError.css; new revision: 1.1.2.2;
mozilla/toolkit/themes/pinstripe/global/netError.css; new revision: 1.1.2.2;
mozilla/themes/classic/global/netError.css; new revision: 1.1.2.2;
mozilla/themes/modern/global/netError.css; new revision: 1.1.2.2;
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → mozilla1.8beta5
Status: RESOLVED → VERIFIED
Target Milestone: mozilla1.8beta5 → mozilla1.9alpha

Comment 10

12 years ago
This caused bug 317372, "XUL error page allows error message to accept focus".
You need to log in before you can comment on or make changes to this bug.