Ability to exclude sites from caching

RESOLVED DUPLICATE of bug 93348

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 93348
13 years ago
13 years ago

People

(Reporter: elijahdjmarshall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

I had asked of Microsoft many times but they wont listen.
As a developer I would find it most beneficial if you were to provide 2 settings
for the Firefox browsers cache.
If we developers were given the option in the settings to register our
development urls that were not to be cached and have this seperated from general
web browsing caching it would aid in the following.
Developers would always know that the data they are viewing is their latest code.
General web browsing data would be cached thus keeping browsing of the common
sites quick since the browser would be pulling from cache.

Reproducible: Always

Comment 1

13 years ago
Easy. Talk to your webmaster - he/she will add the necessary HTTP-header. Or add
it in you application itself (in PHP it's done with "header").

PS : you can disable your disk-cache in about:config, by setting
browser.disk.cache.enable to false. You can also switch off your memory-cache
(browser.memory.cache.enable), but some sites might not work with this.

Updated

13 years ago
Summary: A cache for developers a cache for browsing → Ability to exclude sites from caching

Comment 2

13 years ago
Duplicate of Core bug 93348?

*** This bug has been marked as a duplicate of 93348 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 4

13 years ago
V/dupe.

Probably this would be best implemented as a feature of a tree-based network preference scheme, where you could hang any number of network behaviors (image blocking, cookie management) off part of the DNS tree. I wrote an RFE for it, but it was so long ago, I can't remember the title.
QA Contact: general → benc
You need to log in before you can comment on or make changes to this bug.