Cannot upload extension if Netscape's maxVersion is greater than 1.0.3 but 8.0.3.3 is required for extensions to install

RESOLVED DUPLICATE of bug 305811

Status

--
major
RESOLVED DUPLICATE of bug 305811
14 years ago
3 years ago

People

(Reporter: morac, Assigned: Bugzilla-alanjstrBugs)

Tracking

unspecified
x86
Windows XP

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The latest version of Netscape is 8.0.3.3.  If the maxVersion field for the
Netscape application, {3db10fab-e461-4c80-8b97-957ad5f8ea47}, in an extension's
install.rdf file is less than 8.0.3.3, Netscape will not allow the extension to
install.  If the maxVersion is set to 8.0.3, Netscape will reject the extension
install.

The addons.mozilla.org site will not allow any extension to be uploaded that
contains a maxVersion of greater than 8.0.3 for Netscape.  This means that no
extensions that are compatible with the current version of Netscape 8.0 can be
uploaded.

The maxVersion check should be raised to less than or equal to 8.0.3.3.



Reproducible: Always

Steps to Reproduce:
1. Create an extension that is compatible with Netscape 8.0.3.3 and use a
maxVersion of 8.0.3.3.
2. Try to upload it through the developer's page on
https://addons.mozilla.org/developers/main.php


Actual Results:  
Received the following error:

Error! The MaxAppVer for Netscape of 8.0.3.3 in install.rdf is invalid.
Errors were encountered during install.rdf checking...
Aborting...

Expected Results:  
Allowed the extension to be uploaded since a maxVersion of 8.0.3.3 is required
to install on the latest version of Netscape.
You should change the summary to something like "Cannot upload Netscape
extension if maxVersion is higher than 8.0.3, but 8.0.3.3 is required for
extensions to install".... The current one doesn't make sense, though the
description does. :P
(Assignee)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 305811 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
This has been marked as resolved, but the original bug was never completely
fixed since extensions still can't be installed in Netscape.

A work around would be to put the maxVersion at 8.0.4 which would allow
extensions to be uploaded that could be installed in Netscape 8.0.3.3.  I think
it is highly unlikely Netscape will release a 8.0.4 that is incompatible with
current extensions.
Summary: Cannot upload extension if Netscape's maxVersion is greater than 1.0.3 (need 1.0.3.3 to install) → Cannot upload extension if Netscape's maxVersion is greater than 1.0.3 but 8.0.3.3 is required for extensions to install
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.