If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scrollbars on overflow: scroll and overflow: auto always are initially at the top and left

VERIFIED DUPLICATE of bug 6976

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 6976
18 years ago
18 years ago

People

(Reporter: Matthew Brealey, Assigned: troy)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
For content that overflows the left or top of an element, the scrollbar should 
not initially be at the top and left, but Mozilla currently does this.

See the specified URL, plus 
http://richinstyle.com/test/dynamic/overflowauto.html.

For example, given:
<div style="overflow: scroll">
<div style="margin-left: -40px">
This content will overflow the side of the element
</div>
</div>

In Mozilla the result is:

tent will overflow the side of the element 

with a scrollbar that looks like this
+----------+
|MMM       | 
+----------+
where MMM indicates the scroller, whereas in fact since content is overflowing 
the left of the element, the result should be this:
+----------+
|  MMM     | 
+----------+
This means that when overflow: scroll or overflow: auto, content that overflows 
the left or top of the element can't be seen.
(Assignee)

Comment 1

18 years ago
DUP of bug #6976

*** This bug has been marked as a duplicate of 6976 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
VERIFIED
Status: RESOLVED → VERIFIED
Summary: Scrollbars on overflow: sroll and overflow: auto always are initially at the top and left → Scrollbars on overflow: scroll and overflow: auto always are initially at the top and left
You need to log in before you can comment on or make changes to this bug.