CSS "@import" directives not parsed in "Save page as..." option.

RESOLVED DUPLICATE of bug 126309

Status

()

Firefox
File Handling
--
major
RESOLVED DUPLICATE of bug 126309
12 years ago
12 years ago

People

(Reporter: Andre Sihera, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Examination of the saved files directory reveals that a CSS file does not
get downloaded. However, other web sites that reference CSS files do have
their CSS files downloaded ok. This particular CSS file is referenced not
from within a <link>...</link> tag but through an "@import..." directive
within an inline block of CSS within the page itself.

While you're in this area of the code, can we please fix the "nuance" about the
page being saved with the name of the web page instead of the web page TITLE?
What use are a group of saved pages when they're all called "index.htm"?
It is not the job of an extension to be fixing this kind of problem as it is
unwise to assume that, because there is an extension to fix this, your average
user will be able to find out about the existence of the extension and then
install it. Firefox may be good but user-ubiquity will be impossible if they
have to install numerous extensions to fix fundamental UI integration breaks
like this. It should be fixed in code.


Reproducible: Always

Steps to Reproduce:
1. Browse to web page specified
2. Choose "Save file as..." from the file menu.
3. Save the file.
4. Open the saved file from disk.

Actual Results:  
The layout is scrambled.


Expected Results:  
The layout should reflect the original page.
(Reporter)

Updated

12 years ago
Summary: CSS "@import" directives not parsed in "Save file as..." option. → CSS "@import" directives not parsed in "Save page as..." option.

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.