Print Preview freezes Mozilla

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: vhaarr+bmo, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
1. Download or compile a clean recent build of Seamonkey or Firefox.
2. Click File->Print Preview

Results: Freeze.

I did not experience this when testing the patch for bug 146399 comment 3, so
the regression window would be within the last 3 days.
(Reporter)

Comment 1

13 years ago
Hrm, I just noticed that Print Preview freezes in Firefox 1.0.7 and Mozilla
1.7.12 as well, so this is either something that got into the branch, or it
might be a problem in Ubuntu Breezy.
(Reporter)

Comment 2

13 years ago
I downloaded 1.0.6 and it does indeed freeze, too.
This leads me to believe that it is a problem in Ubuntu, and not Mozilla.

Filed <http://bugzilla.ubuntu.com/show_bug.cgi?id=16143>.
Print preview of about:blank worksforme with a nightly optimized Linux GTK1
Seamonkey build from 2005-09-22-07...

Comment 4

13 years ago
Removing regression keyword for now then.
Keywords: regression
(Reporter)

Comment 5

13 years ago
It's quite apparent that this is a distro issue.

I find it weird that Mozilla never times out from trying to connect and does not
recover in any way, however.

Think we should open a new bug for that issue, keep this one open, or is it very
hard to solve some reason? Seeing as every other application on my desktop
behaved the same way, I guess it's not easily dealt with.

In any case the problem is gone here now, so I can't reproduce this bug any
more. Why the problem is gone, I have no idea.

Comment 6

13 years ago
P4 2.4, 512MB Ram.  

Windows 2k Pro SP 4.  

Mozilla 1.7.12 (and Moz. 1.8b).

Under the above settings, Mozilla freezes on Print Preview, or
even selecting a different zoom %.  

After a minute or two, it resumes operation with the view changed
to the specification.   This happens *EVERYTIME* when the
user changes views.

Viewing a JPG file.  1250x 956 pixel.

Comment 7

13 years ago
As an addendum, I have 4 jpgs with resolutions of 1250x956, 1193x548, 
1142x1154, and 1200x1039.   And I have reproduced this test at different
times and with two different machines and have discovered that between clicking on "Print Preview" and the actual screen updating takes about 29 seconds.  On all 4 jpgs and I have reproduced this test on 
my machine (P4 3.0, 1Gig mem, Win2k Pro sp4, Moz. 1.7.12)  and on another one
(previously stated info: Win2k Pro, sp4, P4 2.4, 512MB, 1.7.12).  

However, what is frustrating that if I selected print preview,
wait until it refreshes, then quickly select the View shrink %,
the screen automatically changes to the correct view.   But on
some occassions(particularly if I want to re-enlarge it), it 
reverts back to the 29 sec rule.  




Comment 8

13 years ago
Print preview on www.myrxhealth.com (haven't tried other sites), running Windows ME (sorry!) [just clean reinstalled OS] and using Firefox 1.0.7 (brand new installation).  Have not tried on other web pages because completely freezes, have to Ctrl-Alt-Delete.  Does not happen on same web page on Firefox 1.0.3 running under Windows XP on same home network/ISP.  
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.