Closed Bug 309776 Opened 14 years ago Closed 14 years ago

Add pref UI (checkbox) for prefetching

Categories

(Firefox :: Preferences, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 269120

People

(Reporter: golden_moon_rising, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

You guys get a lot of bad press from people I talk to because of this. People
are comparing your team's dictatation of "forced prefetch on by default" with
Microsoft's heavy-handed approach towards thrusting unwanted features on users.

This bug still exists in the Firefox 1.0.6.

Frankly, this is the WORST bug I've found in Firefox.

Please fix.  There should be an easy-to-use, UI feature to ENABLE prefetching.

It should be DISABLED by default.

https://bugzilla.mozilla.org/show_bug.cgi?id=166648

Reproducible: Always




Search for "selinux" on Google, and the next thing you know, your browser is
trying to store a cookie from the CIA!

This doesn't help make users into Firefox converts, violates our privacy, and
frankly **** people off, when they realize what Firefox is doing.
Severity: normal → enhancement
See also bug 295558.
See also bug 175104, "disable Link Prefetching by default" (WONTFIX).
Summary: Prefetch Enable/Disable UI Button → Add pref UI (checkbox) for prefetching

*** This bug has been marked as a duplicate of 269120 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
I'm sad that the dev team lacks the courage to empower users with a UI control
to disable prefetching.
You need to log in before you can comment on or make changes to this bug.