Absolutely positioned block element with opacity layered over Flash causes Flash object to disappear

RESOLVED DUPLICATE of bug 309790

Status

()

RESOLVED DUPLICATE of bug 309790
13 years ago
13 years ago

People

(Reporter: af76, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Layering an absolutely positioned block element with CSS opacity of less than 1
over a Flash object causes the the Flash object to become invisible.  The Flash
object must have its wmode set to transparent.  Removing the opacity results in
correct rendering.  Removing the wmode=transparent results in a visible Flash
object, but the block element is shown behind it, even if the z-index of the
element is higher than the Flash object.

Opacity On: <a
href="http://tisch.nyu.edu/page/opacityon">http://tisch.nyu.edu/page/opacityon</a>

Opacity Off: <a
href="http://tisch.nyu.edu/page/opacityoff">http://tisch.nyu.edu/page/opacityoff</a>

This was first noticed on the following page, where the "About Tisch" dropdown
menu slightly overlaps the Flash movie: <a
href="http://www.tisch.nyu.edu/">http://www.tisch.nyu.edu/</a>

This bug does NOT apply to Firefox 1.0.x on Mac or Windows. This only applies to
Firefox 1.5 on Mac OS 10.4.2.  I haven't tested on Windows or other systems.

Reproducible: Always

Steps to Reproduce:
1. Embed a Flash object with wmode=transparent in page
2. Absolutely position a block element over the Flash object
3. Set CSS opacity on block element to less than 1

Actual Results:  
The block element is shown correctly, but the Flash object is invisible.  The
Flash object still has clickable links and the sound works.

Expected Results:  
The block element should be layered (with opacity) over the visible Flash object.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 309790 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.