Firefox wont start after cancelled upgrade to 1.07

RESOLVED DUPLICATE of bug 283680

Status

()

Toolkit
Application Update
--
critical
RESOLVED DUPLICATE of bug 283680
13 years ago
10 years ago

People

(Reporter: Linda Cjoleman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Sorry, can't open

2005/09/23 saw the icon in the upper corner that critical upgrades were 
available so I clicked on it to start the upgrade.

When it asked if I wanted to use the custom or standard installer I couldn't 
remember which I had used when I orinially installed so I canceled the upgrade.

Now when I try to start Firefox all i get is a dialog box with the 
title "Error" and the text "The program must clost to allow a previous 
installation attempt to complete. Please restart."  Well, restart what??

I rebooted my computer but that didn't make any difference. There was no 
firefox or mozilla process running but I still can't start mozilla. I'm not 
even sure how to restart the upgrade! :(

Reproducible: Always

Steps to Reproduce:
1.Start upgrade to 1.07
2.Cancel upgrade
3.Try to start firefox

Actual Results:  
a dialog box with the title "Error" and the text "The program must clost to 
allow a previous installation attempt to complete. Please restart."

Expected Results:  
firefox should have started
(Reporter)

Comment 1

13 years ago
install.log contents

-------------------------------------------------------------------------------
http://fpdownload.macromedia.com/get/shockwave/flash/mozilla/flash-7.0.19.0-
win32.xpi  --  2005-07-21 14:44:57
-------------------------------------------------------------------------------

     Macromedia Shockwave Flash (version 7.0.19.0)
     --------------------------

     ** initInstall: 0
     ** pluginsFolder: C:\PROGRA~1\MOZILL~1\plugins\
     ** addDirectory() returned: 0
     [1/4]	Installing: C:\PROGRA~1\MOZILL~1\plugins\GetFlash.exe.manifest
     [2/4]	Installing: C:\PROGRA~1\MOZILL~1\plugins\GetFlash.exe
     [3/4]	Installing: C:\PROGRA~1\MOZILL~1\plugins\NPSWF32.dll
     [4/4]	Installing: C:\PROGRA~1\MOZILL~1\plugins\flashplayer.xpt
     ** performInstall() returned: 0

     Install completed successfully  --  2005-07-21 14:44:57

-------------------------------------------------------------------------------
http://ftp.mozilla.org/pub/mozilla.org/extensions/view_formatted_source_
(format_source_extension)/view_formatted_source-0.9.3.4-fx.xpi  --  2005-08-23 
12:35:31
-------------------------------------------------------------------------------


     Install completed successfully  --  2005-08-23 12:35:32

-------------------------------------------------------------------------------
http://ftp.mozilla.org/pub/mozilla.org/extensions/view_formatted_source_
(format_source_extension)/view_formatted_source-0.9.3.4-fx.xpi  --  2005-08-29 
14:25:58
-------------------------------------------------------------------------------


     Install completed successfully  --  2005-08-29 14:25:58

-------------------------------------------------------------------------------
http://download.mozilla.org/?product=firefox-1.0.7-update&os=win&lang=en-US  --
  2005-09-23 08:00:29
-------------------------------------------------------------------------------

     firefox (version 1.0.7)
     -------

     [1/3]	Installing: C:\Documents and Settings\Linda 
Coleman\Desktop\Firefox Setup 1.0.7.exe
     [2/3]	Executing: C:\DOCUME~1\LINDAC~1\LOCALS~1\TEMP\xpinstall.exe
     [3/3]	Deleting file: C:\Program Files\Mozilla Firefox\xpicleanup.exe

     Install completed successfully  --  2005-09-23 08:00:31

Comment 2

13 years ago
The solution is to delete the xpicleanup.dat file in your Firefox program dir.

*** This bug has been marked as a duplicate of 283680 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.