The default bug view has changed. See this FAQ.

Scroll wheel doesn't scroll list boxes [Mac]

RESOLVED FIXED

Status

Core Graveyard
Widget: Mac
RESOLVED FIXED
12 years ago
7 years ago

People

(Reporter: Mark Mentovai, Assigned: Mark Mentovai)

Tracking

({fixed1.8, regression})

1.8 Branch
PowerPC
Mac OS X
fixed1.8, regression
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [branch only], URL)

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Since the patch for bug 255415/bug 171680 was checked in, rolling a mouse wheel
while the cursor is over an html list box causes the document to scroll.  The
list box should scroll.  This also occurs in ChatZilla.  If the wheel is spun
over a scrollbar, the widget scrolls properly.

This is most likely a result of using FindWidgetHit to locate the widget to
scroll instead of gEventDispatchHandler.GetWidgetPointed().
(Assignee)

Updated

12 years ago
Flags: blocking1.8b5?
(Assignee)

Comment 1

12 years ago
The Bugzilla search page is a good test case.
(Assignee)

Comment 2

12 years ago
We don't see this on the trunk.  I bet that it was event.point vs.
event.refPoint, and I was right.
(Assignee)

Comment 3

12 years ago
Created attachment 197226 [details] [diff] [review]
Fix, use event.point instead of event.refPoint (branch only)

This was my error, I hadn't accounted for the differences caused by bug 296036
between the trunk and the branch.
Attachment #197226 - Flags: review?(bugs.mano)
Attachment #197226 - Flags: approval1.8b5?
Comment on attachment 197226 [details] [diff] [review]
Fix, use event.point instead of event.refPoint (branch only)

r=mano.
Attachment #197226 - Flags: review?(bugs.mano) → review+
Whiteboard: [branch only]
Comment on attachment 197226 [details] [diff] [review]
Fix, use event.point instead of event.refPoint (branch only)

Mark, can you get an SR from someone appropriate first please?
Attachment #197226 - Flags: approval1.8b5?
(Assignee)

Updated

12 years ago
Attachment #197226 - Flags: superreview?(sfraser_bugs)

Updated

12 years ago
Attachment #197226 - Flags: superreview?(sfraser_bugs) → superreview+
(Assignee)

Updated

12 years ago
Attachment #197226 - Flags: approval1.8b5?

Updated

12 years ago
Flags: blocking1.8b5? → blocking1.8b5+

Updated

12 years ago
Attachment #197226 - Flags: approval1.8b5? → approval1.8b5+
(Assignee)

Comment 6

12 years ago
Fixed
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED

Updated

7 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.