useless code in wallet source

RESOLVED FIXED

Status

SeaMonkey
Passwords & Permissions
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: sam@rfc1149.net, Assigned: sam@rfc1149.net)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050815 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050815 Firefox/1.0.6

Some code around line 2310 in extensions/wallet/src/singsign.cpp sets data2 to
the same value as data:

data2 = NS_STATIC_CAST(si_SignonDataStruct*, signonData->ElementAt(j));

data has been set to this very exact value (considering the branch we are in)
and can be used in this block instead of data2

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

13 years ago
Created attachment 197233 [details] [diff] [review]
Fix useless duplicate data

Comment 2

13 years ago
You'll need to seek review from someone if you want your code to be checked-in.

->MAS: Password Manager (Hope that's the right place)
Assignee: nobody → dveditz
Component: Password Manager → Password Manager
Product: Firefox → Mozilla Application Suite
QA Contact: password.manager
Attachment #197233 - Flags: superreview?(bzbarsky)
Attachment #197233 - Flags: review?(neil)

Updated

12 years ago
Attachment #197233 - Flags: review?(neil) → review+
Assignee: dveditz → sam
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #197233 - Flags: superreview?(bzbarsky) → superreview+
Whiteboard: [checkin needed]
Checked in on trunk.  Samuel, thanks for the patch!  I'm sorry it took so long to get checked in; the problem is that generally reviewers only see patches they've been asked for review for.  See http://www.mozilla.org/hacking/life-cycle.html for more info.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
You need to log in before you can comment on or make changes to this bug.