Close tabs confirm dialog prevents quit on log out, shut down, or restart

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
5 years ago

People

(Reporter: Chris Thatcher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Selecting "Shut Down" from the apple menu. Shut Down hangs and won't shut down
because Firefox refuses to quit. 

Reproducible: Couldn't Reproduce




This usually happens if I've had a lot of windows open in tabs previously.
*** Bug 310272 has been marked as a duplicate of this bug. ***
To reproduce:
1. Open a few tabs.
2. Select "Shutdown" from the Apple menu.
3. Note the alert FF gives (Are you sure you want to close these tabs)
4. Select "Cancel"
5. Select "Shutdown" from the Apple menu again.
6. The OS does not shutdown (though I'm assuming it will after 120 seconds when
the OS forces all apps closed).

If FF is closed after "Shutdown" is selected, the OS will shutdown, despite the
"Cancel" option chosen by the user.

Should we be forcing FF closed or allowing FF to control whether the OS shuts
down or not.

Confirming...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

13 years ago
Still there in Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1)
Gecko/20051001 Firefox/1.6a1.  I think the quit message that is sent by the OS
on log out, shut down, and restart is different than that sent when you choose
quit from the application menu and should be handled properly.  Updating summary
to be a bit more informative.
Summary: Won't quit on shut down → Close tabs confirm dialog prevents quit on log out, shut down, or restart

Comment 4

13 years ago
Although bug #310272 was marked as a duplicate, it seems there is a difference. in this we have multiple tabs, in #310272 we dont. would appear that bug #310272 shouldnt happen as nothing is causing the shutdown to fail, here the confirmation box is halting the shutdown. cannot replicate this bug. OSX shuts down everytime, except when another documented bug stops firefox from exiting cleanly, or confirmation box is presented (as here). shutdown works for 1.0 trough 1.5rc3 beta to 1.5.0.1 rc1.

Comment 5

12 years ago
*** Bug 360543 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
*** Bug 347319 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
Rereading my bug 360543 will show that the initial interest was/is scheduled shutdown by Apples shutdown process when computer is left unattended.  If FF tabs are open, the computer will not do a forced shut down and therefore time out.

Shuting down/restarting from the Apple menu tends to do the same FF not attended to.

Comment 8

10 years ago
I also get this bug on Windows VISTA - whether or not multiple tabs are open in FireFox.

Updated

5 years ago
Duplicate of this bug: 301627

Comment 10

5 years ago
This works for me (OS X 10.8, Firefox 21), so marking as such. If you still see this problem, please feel free to reopen. Thank you!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.