Impractical to use multiple client Certificates

RESOLVED DUPLICATE of bug 149673

Status

()

RESOLVED DUPLICATE of bug 149673
13 years ago
11 years ago

People

(Reporter: Peter.Binney, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

If you have multiple client Certificates, Firefox makes you reselect a
Certificate every few actions on the same website.
Because the SSL session has been established this is meaningless and very annoying
(you can select any Certificate, not necessarily the original one that was used
to establish the SSL session).

Thus the only way to operate is:
- set the "Client Certificate Selection" Option to "Ask every time"
- log into the web site
- set the "Client Certificate Selection" Option to "Select automatically"
- continue using the web site

This is highly impractical; Firefox should operate like IE, which works as you'd
expect.

Reproducible: Always

Steps to Reproduce:
See "Details"
Actual Results:  
See "Details"

Expected Results:  
See "Details"

Comment 1

13 years ago
Related to Core bug 149673?
(Reporter)

Comment 2

13 years ago
Yes, sounds very like 149673 (which I didnt' find on my pre-reporting search, 
because I was looking under Firefox).
But, as my description shows, the prompt/reselect is actually meaningless, 
since the SSL session has already been established.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.0 Branch

Comment 4

11 years ago
This problem does still exist with the current version of Firefox. 

Comment 5

11 years ago
I'm not sure how IE handles this, but there could be a sub-option to "Select automatically" which would allow the user to select a default certificate (and not just the first one on the list).

The problem sill exists with Firefox 2.

Comment 6

11 years ago
This is a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 149673
You need to log in before you can comment on or make changes to this bug.