All day event (> two days) not visible in week view [JavaScript Error: "allDayBox has no properties"]

RESOLVED DUPLICATE of bug 308993

Status

RESOLVED DUPLICATE of bug 308993
13 years ago
13 years ago

People

(Reporter: ssitter, Assigned: mostafah)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050923 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050923 Mozilla Sunbird/0.2+

An all day event (with two days or more) is displayed fine in multiweek and
month view. Event is not displayed in week view. Error message in JavaScript
Console.

Reproducible: Always

Steps to Reproduce:
1. Create All Day event with two days, e.g. 24-Sep-2005 to 25-Sep-2005
2. Select week view
Actual Results:  
Event is not displayed in week view. Error in JavaScript Console:

-----------------------------------------------------------------------
Error: allDayBox has no properties
Source File: chrome://calendar/content/weekView.js
Line: 492
-----------------------------------------------------------------------
Error: uncaught exception: [Exception... 
"'[JavaScript Error: "allDayBox has no properties" 
{file: "chrome://calendar/content/weekView.js" line: 492}]' 
when calling method: [calIOperationListener::onOperationComplete]"  
nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  
location: "JS frame :: 
           file:///D:/sunbird/components/calCompositeCalendar.js ::
           anonymous :: line 404"  data: yes]
-----------------------------------------------------------------------


Expected Results:  
Event is displayed in week view.

Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20050923 Mozilla Sunbird/0.2+
(Reporter)

Comment 1

13 years ago
Additional info:

"Options - View - First day of week" is set to Sunday:
All day event: 23-Sep to 24-Sep - no error, event is displayed fine
All day event: 24-Sep to 25-Sep - no error, event is displayed fine

"Options - View - First day of week" is set to Monday:
All day event: 23-Sep to 24-Sep - no error, event is displayed fine
All day event: 24-Sep to 25-Sep - error occurrs, event is not displayed

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 308993 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.