If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

High CPU usage, and increasing memory consumption upon opening specific URL

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Ignacio Carrera, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Just opening the specified URL, the CPU usage keeps steady at [70..90]%, and
memory consumption keeps steadily incresing, at a high rate (in less than a
minute it went from ~20mb, to over 150mb). Closing that single tab drops both
parameters, but memory consumption is still a little high (perhaps some caching
or something).  When left a few minutes to see what happened, it eventually
crashed (and, before that, the UI became ever less responsive). Tested on:

- Firefox 1.4 (Deer Park Beta 1, 1.8b4, Gecko/20050908, wXP-SP2): shows bug
- Firefox 1.0.7 (1.7.12, Gecko/20050919, wXP-SP2): works fine

Reproducible: Always

Steps to Reproduce:
1. open Task Manager or any resource monitor (optional, you can feel the browser
less responsive)
2. open http://www.onlamp.com/pub/wlg/7887 while watching the monitor 
3. wait a few seconds

Actual Results:  
CPU usage: 70% < x < 90%
Firefox's Memory Usage: grew at a high rate (more than 60mb a minute)
Browser responsiveness: crawling

Expected Results:  
Keep it resource usage as low as possible.

- Default theme
- Talkback ID TB9686333X
- Pentium 3 1000Mhz (FSB133), 512mb RAM, 80gb ATA133, running Windows XP Service
Pack 2 (I might try it later on Linux... but I didn't install Deer Park there)
- Build config: just downloaded binary as posted to mozilla.org (i586-pc-msvc,
--enable-application=browser --enable-update-channel=beta --enable-optimize
--disable-debug --disable-tests --enable-static --disable-shared
--enable-official-branding --enable-svg --enable-canvas --enable-update-packaging)
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050923
Firefox/1.6a1 ID:2005092321

WFM in trunk and branch; CPU usage 3-18% due to the flash advertisement.
Without flash 3-5%. 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050924
Firefox/1.4 ID:2005092401

WFM
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20050924
> Firefox/1.4 ID:2005092401
> 
> WFM

Sorry, do you know where to find a binary package for 1.8b5?

Comment 4

12 years ago
Latest branch 1.8 builds:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/

Latest trunk builds:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> Latest branch 1.8 builds:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8/
> 
> Latest trunk builds:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

Thanks, tried 2005-09-25. It's certainly better, though still showing the same
behaviour (its CPU usage is a little lower, say ~50-60% and memory consumption
doesn't grow so abruptly, but still higher than other
full-of-flash-ads-and-stuff pages).

I don't know what more could I try. On the other hand, seeing improvement in
this regard, I'd think this is something that's being addresed and close this bug.

NachoKB

Comment 6

12 years ago
Same think happens here. Memory keeps increasing visiting the referenced site.

It also happens with:
http://www.duluthsuperior.com/mld/duluthsuperior/business/technology/12783050.htm

Tested with Firefox 1.5 B1 + WinXP PRO SP2. It also happens with Win2000 SP4
(Reporter)

Comment 7

12 years ago
(In reply to comment #6)
> Same think happens here. Memory keeps increasing visiting the referenced site.
> 
> It also happens with:
> http://www.duluthsuperior.com/mld/duluthsuperior/business/technology/12783050.htm
> 
> Tested with Firefox 1.5 B1 + WinXP PRO SP2. It also happens with Win2000 SP4

Happened to me also. But somehow slower. (1.5b1)

Comment 8

12 years ago
This bug does not occur with Javascript disabled.
With Javascript enabled firefox memory keeps getting larger.

My configuration same as last time, only change is that i use nightly build of
03/09/2005 (1.8).

Comment 9

12 years ago
This bug is fixed in the nightly build of 18-Oct-2005 (latest-mozilla 1.8).

Both of the URLs mentioned above are working fine without memory leaks.

Nice work guys and thank you. There will be a lot less firefox crashes now(at
least for me).

A propose to resolve the bug to fixed.

Comment 10

12 years ago
Scratch the previous post. 

This bug is triggered by enabling AdBlock and going to the above URLs. (i should
have tested with disabled extensions before).



Comment 11

11 years ago
The original URL http://www.onlamp.com/pub/wlg/7887 WFM.
The page has apparently changed because it no longer has flash content.
-> WFM
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a4pre) Gecko/20070427 Minefield/3.0a4pre

comment 6 URL no longer exists and goes to a different page. If that page is similar then the issue there could be javascript (slide show), flash, something else or a combination. There are plenty of existing bugs to choose from.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.