selecting links on wirelessadvisor site with Firefox 1.0.7 crashes [@ 0x4167ca72 - libglib-2.0.so.0 + 0x25bec]

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
--
critical
RESOLVED WORKSFORME
13 years ago
7 years ago

People

(Reporter: Edward, Assigned: blizzard)

Tracking

({crash})

1.7 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9a1) Gecko/20050924 SeaMonkey/1.1a
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9a1) Gecko/20050924 SeaMonkey/1.1a

Firefox 1.0.7 (Linux) repeatedly crashes on the above page when links are
selected.  TalkBack reported "Program Exception" each time, see below for crash
ID's.  

Reproducible: Always

Steps to Reproduce:
1.Load http://forums.wirelessadvisor.com/
2.Click a link
3.Firefox crashes and launches TalkBack.

Actual Results:  
Browser crashed.

Expected Results:  
Browser should have displayed the selected page without crashing.

Talkback crash ID's:  

Program Exception

TB9699916M
TB9700011G
TB9700082H
(Reporter)

Comment 1

13 years ago
Firefox User-Agent and Build Identifier for this bug:

Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Comment 2

13 years ago
hrm, you're going to either need to get someone to reproduce this, or get
symbols for glib, and build yourself (--enable-debugger-info-modules ?)

Incident ID: 9699916
Stack Signature	0x4167ca72 c26a6a37
Product ID	Firefox10
Build ID	2005092015
Trigger Time	2005-09-24 18:45:22.0
Platform	LinuxIntel
Operating System	Linux 2.4.21-297-default
Module	
URL visited	http://forums.wirelessadvisor.com/
User Comments	Submitted form information, Firefox crashed.
Since Last Crash	0 sec
Total Uptime	0 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
0x4167ca72
libglib-2.0.so.0 + 0x25bec (0x4056cbec)
libglib-2.0.so.0 + 0x23148 (0x4056a148)
libglib-2.0.so.0 + 0x241a8 (0x4056b1a8)
libglib-2.0.so.0 + 0x245a8 (0x4056b5a8)
libglib-2.0.so.0 + 0x24bf7 (0x4056bbf7)
libgtk-x11-2.0.so.0 + 0xd36ff (0x4028f6ff)
nsAppShell::Run() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/widget/src/gtk2/nsAppShell.cpp,
line 144]
nsAppShellService::Run() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 495]
xre_main() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 692]
main() 
[/builds/tinderbox/Fx-Aviary1.0.1/Linux_2.4.20-28.8_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 59]
libc.so.6 + 0x15d3e (0x4093bd3e)

for the time being, please file a new bug for TB9700011G (you can click on
TB.... items to see the stack traces, and if you do, you'll see that it doesn't
match the other two you listed)
Keywords: crash
Summary: Program Exception - Firefox 1.0.7 crashes → Program Exception - Firefox 1.0.7 crashes [@ 0x4167ca72 - libglib-2.0.so.0 + 0x25bec]
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050922
Firefox/1.4 ID:2005092206

No crash in 1.0.7, trunk and branch using Windows XP. Tried nearly all links. :)
(Reporter)

Comment 4

13 years ago
Windows XP release works fine with that page, only the Linux release kept crashing.

Comment 5

13 years ago
we think this /could/ be bug 310137, but w/o symbols for the gtk2/glib stuff,
it's hard to tell.

if you have symbols and can use gdb to get a stack trace for the gtk2/glib side
of things and report that and the talkbackincident id, that'd enable us to
confirm the problem...
Assignee: nobody → blizzard
Component: General → Widget: Gtk
Product: Firefox → Core
QA Contact: general → gtk
Version: unspecified → 1.7 Branch

Updated

12 years ago
Summary: Program Exception - Firefox 1.0.7 crashes [@ 0x4167ca72 - libglib-2.0.so.0 + 0x25bec] → selecting links on wirelessadvisor site with Firefox 1.0.7 crashes [@ 0x4167ca72 - libglib-2.0.so.0 + 0x25bec]

Comment 6

12 years ago
bclary was unable to reproduce using todays trunk build on linux.  anyone able to see the crash still?

Comment 7

12 years ago
WFM on recent branch.
(Reporter)

Comment 8

12 years ago
I'm closing this bug report as this issue eventually cleared up on its own and has not been a problem for me for quite some time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ 0x4167ca72 - libglib-2.0.so.0 + 0x25bec]
You need to log in before you can comment on or make changes to this bug.