Last Comment Bug 309935 - SeaMonkey ignores Acrobat plug-in directives, brings up handling dialog box instead
: SeaMonkey ignores Acrobat plug-in directives, brings up handling dialog box i...
Status: RESOLVED FIXED
: fixed1.8.0.5, fixed1.8.1
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 98
: P1 normal with 2 votes (vote)
: mozilla1.8.1
Assigned To: Christian :Biesinger (don't email me, ping me on IRC)
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
: 316129 339166 340927 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-24 22:13 PDT by Debbie Kraft
Modified: 2006-06-16 11:43 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (977 bytes, patch)
2005-11-12 16:09 PST, Christian :Biesinger (don't email me, ping me on IRC)
aaronlev: review+
roc: superreview+
dveditz: approval1.8.0.1-
dveditz: approval1.8.0.5+
dveditz: approval1.8.1+
Details | Diff | Splinter Review

Description Debbie Kraft 2005-09-24 22:13:21 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a Mnenhy/0.7.2.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b4) Gecko/20050910 SeaMonkey/1.0a Mnenhy/0.7.2.0

I have Adobe Acrobat 5.0.5 installed on my Win 98SE OS, and within that
program's preferences, I've chosen the option "Display PDF in browser."  This
(correctly) copies the Acrobat plug-in (nppdf32.dll, ver. 5.00) to the SeaMonkey
plugins subdirectory.

Using SeaMonkey build 20050812 (before the skinVersion change), the browser
recognized the plug-in and displayed all PDF documents within a browser window
or tab.  With SeaMonkey 1.0a (installed clean to a new profile), the Acrobat
plug-in is included on the about:plugins list, and is marked as enabled. 
However, when clicking on any link associated with a PDF document, SeaMonkey
1.0a brings up a handling dialog box ("What do you want SeaMonkey to do with
this file?") instead of making use of said plug-in.

Reproducible: Always

Steps to Reproduce:
1. Start SeaMonkey 1.0a browser on Win 98 system with Adobe Acrobat 5.0.5;
latter program should have preferences option "Display PDF in browser" checked
2. Click on link to any PDF document
3. Example:  http://www.missouri.edu/~tigers/Smith_et_al.pdf

Actual Results:  
SeaMonkey 1.0a brings up an Opening dialog box, asking how it should handle PDF
files (options include: open with default app (Adobe Acrobat), open with..., and
save to disk).

Expected Results:  
The browser should have made use of the Acrobat plug-in and displayed the PDF
document within the browser window or tab.

It has been suggested that installation of the current free Acrobat Reader (ver.
6.0.4) may resolve this difficulty through updating the plug-in file
nppdf32.dll.  However, this may also cause a conflict between the full Acrobat
software and the free Reader with future PDF document handling.  Since I rely on
the Acrobat software for frequent document conversion, I don't wish to chance
this.  The Reader also cannot be uninstalled independent of the full software.

Additionally, the version 5.00 plug-in worked for the 20050812 build, leading me
to believe a change in SeaMonkey 1.0a is at the heart of this behavior.

It should be noted that version 5.0.5 of the Acrobat software is the only
version compatible with Win 98--Adobe will not be releasing any updates to its
Acrobat software for the Win 98 OS.
Comment 1 Benoît 2005-09-25 03:26:53 PDT
Confirming.

I have the free Acrobat Reader 5.0.5 installed on my Windows 95 PC. I also have
the option to display PDF files in the browser enabled, and have the plug-in
installed. I'm seeing the same behavior.

Additionally, 50% of the time I click on a link opening a PDF file, the file
handling dialog box shows up and immediately places itself in the background,
behind the SeaMonkey window, unfocused.
Comment 2 Andrew Schultz 2005-09-25 11:55:40 PDT
==> plugins
Comment 3 OstGote! 2005-09-25 23:47:02 PDT
Please check the value of the pref plugin.scan.Acrobat, use about:config to
check it.
Comment 4 Debbie Kraft 2005-09-27 08:39:32 PDT
(In reply to comment #3)
> Please check the value of the pref plugin.scan.Acrobat, use about:config to
> check it.

My settings are as follows:  default   string   5.0

Unfortunately, since I no longer have build 20050812 on my computer, I can't
make a cross-comparison.
Comment 5 Debbie Kraft 2005-10-12 00:16:38 PDT
-- Update --

Due to my PC's SCSI HD suffering a spindle/motor failure, I had to resort to my
laptop for computer work, also using Win 98SE.  SeaMonkey 1.0a wasn't installed,
and neither was Adobe Acrobat.  Installed the former to a new profile, and
installed Acrobat Reader 6.0.4 (after updates).  The latter's
plug-in--nppdf32.dll--has a version number of 6.0.0.2003051500.  SeaMonkey
doesn't recognize this version of the plug-in either, even with the config
option plugin.scan.Acrobat set to "6.0."  I've also tried setting it to the
plug-in's specific version number, 6.0.0.2003051500, without any success.

It appears that plugin.scan.Acrobat isn't functioning properly for any Acrobat
plug-in version on Win 95/98 systems.  I wonder what the difference is with the
Win 2000/XP plug-in(s) that this bug isn't seen with that OS...


Comment 6 Andrew Schultz 2005-11-11 21:32:48 PST
*** Bug 316129 has been marked as a duplicate of this bug. ***
Comment 7 Christian :Biesinger (don't email me, ping me on IRC) 2005-11-12 15:42:49 PST
hmm, mozilla believes that a screen reader is active.
Comment 8 Christian :Biesinger (don't email me, ping me on IRC) 2005-11-12 16:09:16 PST
Created attachment 202848 [details] [diff] [review]
patch

this function returns a BOOL, not a HRESULT. Unfortunately I can't test this patch with a screenreader active; aaronlev, could you do that?
Comment 9 Christian :Biesinger (don't email me, ping me on IRC) 2005-11-12 16:40:52 PST
The reason this is an issue is that on WinXP, this function returns TRUE (1), and a zero value for the screen reader presence; while on win98, it returns FALSE for me, leaving the value as-is, which means it's a pretty random value, which gets interpreted as true, of course.
Comment 10 Christian :Biesinger (don't email me, ping me on IRC) 2005-11-12 16:42:10 PST
(and SUCCEEDED is true for any positive value)
Comment 11 Christian :Biesinger (don't email me, ping me on IRC) 2005-11-12 16:42:28 PST
that is, non-negative value
Comment 12 Christian :Biesinger (don't email me, ping me on IRC) 2005-12-17 06:21:50 PST
fixed on trunk:
Checking in widget/src/windows/nsLookAndFeel.cpp;
/cvsroot/mozilla/widget/src/windows/nsLookAndFeel.cpp,v  <--  nsLookAndFeel.cpp
new revision: 1.53; previous revision: 1.52
done
Comment 13 Christian :Biesinger (don't email me, ping me on IRC) 2005-12-17 06:23:34 PST
Comment on attachment 202848 [details] [diff] [review]
patch

this is a low-risk patch that fixes the PDF plugin (and maybe others), by handling errors from SystemParameterInfo correctly. (mostly a win9x issue)
Comment 14 Mike Schroepfer 2005-12-19 15:53:47 PST
Can we bake for longer on the trunk and then we'll consider for the branch.
Comment 15 Daniel Veditz [:dveditz] 2006-01-05 11:19:10 PST
Comment on attachment 202848 [details] [diff] [review]
patch

Not taking for 1.8.0.1
Comment 16 Christian :Biesinger (don't email me, ping me on IRC) 2006-01-05 12:20:41 PST
ah well. fixed on MOZILLA_1_8_BRANCH:
Checking in widget/src/windows/nsLookAndFeel.cpp;
/cvsroot/mozilla/widget/src/windows/nsLookAndFeel.cpp,v  <--  nsLookAndFeel.cpp
new revision: 1.50.2.3; previous revision: 1.50.2.2
done
Comment 17 Benoît 2006-05-25 06:06:37 PDT
*** Bug 339166 has been marked as a duplicate of this bug. ***
Comment 18 Christian :Biesinger (don't email me, ping me on IRC) 2006-06-15 14:29:15 PDT
*** Bug 340927 has been marked as a duplicate of this bug. ***
Comment 19 Daniel Veditz [:dveditz] 2006-06-15 14:36:37 PDT
Comment on attachment 202848 [details] [diff] [review]
patch

approved for 1.8.0 branch, a=dveditz for drivers
Comment 20 Christian :Biesinger (don't email me, ping me on IRC) 2006-06-16 11:43:17 PDT
MOZILLA_1_8_0_BRANCH:

Checking in widget/src/windows/nsLookAndFeel.cpp;
/cvsroot/mozilla/widget/src/windows/nsLookAndFeel.cpp,v  <--  nsLookAndFeel.cpp
new revision: 1.50.2.2.2.1; previous revision: 1.50.2.2
done

Note You need to log in before you can comment on or make changes to this bug.