table layout broken by <!--QuoteBegin--Ren-+Sep 25 2005, 08:02 AM--> comment

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Kutovoy Nickolay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

If u remove line <!--QuoteBegin--Ren-+Sep 25 2005, 08:02 AM--> from page in URL,
layout will be built right, or if u just remove two '--' before 'Ren', otherwise
it goes wrong. In IE works well, sorry if duplicate/stupid. ;(

Seen in 1.0.6, 1.0.7 Firefox, m.b. earlier too.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.kutovoy.com.ua/ff_error.html
Actual Results:  
Broken web page

Expected Results:  
Open IE, go http://www.kutovoy.com.ua/ff_error.html, correct table will be built.
(Reporter)

Comment 1

13 years ago
Created attachment 197341 [details]
HTML which cause error

Comment 2

13 years ago
Invalid see http://www.w3.org/TR/html401/intro/sgmltut.html#h-3.2.4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> Invalid see http://www.w3.org/TR/html401/intro/sgmltut.html#h-3.2.4

Hi, thanks for reply, but line

<!-- QuoteBegin--Ren-+Sep 25 2005, 08:02 AM -->

still cause error. I readed
http://www.w3.org/TR/html401/intro/sgmltut.html#h-3.2.4, there is note about
"Authors _should_ _avoid_ putting two or more adjacent hyphens inside
comments.", but this is note only, not an requirment. Page is displayerd as
broken only due to 'two or more adjacent hyphens inside comments'. ;( Such error
caused by IPB forum software v1.3x (only open source && free version available)
and installed on huge ammount of web sites and visited by FireFox users. Quoting
user's (with name with '-' at start or end) post will cause such comment and
such error. We really will like u if that will be supported... If no... We like
u all for the FireFox at all :)

Thanks!

Comment 4

13 years ago
I was commenting the wrong section of the w3 documentation. The page has a
doctype of XHTML 1.0 Transitional which is follows the XML comment rules.
http://www.w3.org/TR/REC-xml/#sec-comments

Also
http://developer.mozilla.org/en/docs/Gecko_Compatibility_Handbook#Invalid_Comments
http://developer.mozilla.org/en/docs/HTML:The_Importance_of_Correct_Commenting#XML
You need to log in before you can comment on or make changes to this bug.