Closed Bug 309978 Opened 17 years ago Closed 17 years ago

Popup not working! nsIDOMJSWindow.open, 0x80004005 (NS_ERROR_FAILURE)

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 309775

People

(Reporter: marc.bau, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://localhost/partner/booking.cfm?action=open :: onclick :: line 1"  data: no]

Reproducible: Always

Steps to Reproduce:
1. create html with following code
2. <a href="#"
onclick="window.open('bookinginfo.cfm?bookingnr=12345','PopUp','width=300,height=140,screenX=150,screenY=0');"
class="nav04" title="Booking-No 12345">12345</a>
3. click on 12345
4. popup window do not open
5. see java script console

Actual Results:  
popup do not open

Expected Results:  
popup MUST open!
sorry, i removed in the links my sessionid. but they looks releated to the bug!
looks like your new URL filtering is too heavy!

no popup and the known error:
http://localhost/partner/booking.cfm?action=open&CFID=146915639&CFTOKEN=2ea962169593de63-81CEA59A-E391-65A2-D8114ACD30575BAB#


popup is opening:
http://localhost/partner/booking.cfm?action=open#
AHHHH - SORRY for the confusion. i klicked in IE... and tetested there. this bug
is not releated to the sessionID's!
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050925
Firefox/1.4 ID:2005092505

WFM. Get a popup, no error in the JS Console.
hm... today i tryed another time. only thing i have done is - i have restarted
my browser running on the last test a long time. now it works for me, too. 

there is something rotten...
Related to/duplicate of Core bug 309775 (+ bug 309170, Core bug 177819 and/or
Thunderbird bug 290924)?
Marking duplicate of 309775 will add reporter as cc of 309775

*** This bug has been marked as a duplicate of 309775 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.