Closed Bug 309989 Opened 17 years ago Closed 15 years ago

Wrong "image loading" image displayed

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 272534
Camino1.6

People

(Reporter: alqahira, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(2 files)

Occasionally (not in every build, thankfully), Camino displays the ugly Firefox
"red blob" missing image graphic for a loading image.  Camino 2005092404
(v1.0a1+) is one such build.  

I've checked the package and Camino.app/Contents/MacOS/res/loading-image.gif is
the expected green box with elipsis, and even
Camino.app/Contents/MacOS/res/broken-image.gif is the red box with the question
mark.
Attached file Testcase
This testcase uses example.com for the image, so it'll keep trying to load the
image for some time.
Where would that image even be pulled from?

Of note: The testcase doesn't work for me as when it times out it shows the alt
text instead of the any red error image. I'm using 1.0a1.

In how many builds does this happen? Or is this something that regressed?
(In reply to comment #3)
> Where would that image even be pulled from?

That's what I want to know!  (Maybe the Fx version ends up in embed.jar?)

> Of note: The testcase doesn't work for me as when it times out it shows the alt
> text instead of the any red error image. I'm using 1.0a1.

You don't see it while the page/image is loading, before it times out?  (I think
the collapsing down to the alt text is, or should be, a Core bug.)
 
> In how many builds does this happen? Or is this something that regressed?

No, it happens randomly, occasionally.  I noticed it in a build last week, and
then again in the 24th's build, so I filed.

Oddly enough, when I restarted Camino to enter this comment and then tried the
testcase, I get the proper image.  That seems to confirm that the wrong image is
shipped with Camino all the time, but I still don't know what triggers it to
show up sometimes....
AFAIK this isn't build-specific; it's happened to me before, and a quit+relaunch
of Camino usually makes it go away (it is still a problem, though).
What Wevah said. I've been noticing this at least since July or so, and I
mentioned it over on MZ when I first noticed it. Everyone told me I was on crack ;)

cl
I've seen it even earlier than July, though I can't name a specific
"first-notice" date.
i've seen this from time to time, usually when the app has been running for a
very long time.
Target Milestone: --- → Camino1.2
When I was going through old builds tracking down the regression in bug 306245,
I saw this a lot (more frequently the older the build was).  Since I was using
each build for only a minute or two, Camino having been running for a long time
is not the only time when it can appear.
I've been seeing this very, very frequently in 1.8 branch nightlies of late (and I almost always see it starting right at startup).
OS: Mac OS X 10.2 → Mac OS X 10.3
grr, stupid new UI
Assignee: mikepinkerton → nobody
QA Contact: general
I'm seeing this about every other launch now :(

New URL (a pawn graph that will never end up loading) should give a good look at the weird red blob image....
It seems that it happens every time with me if I restart Camino using the 'Reopen...' button in the Mac O X crash dialog... I goes away if I quit Camino and start it from the Dock tho...
Oh, I am using my own 1.1a2+ branch build on a PPC Mac OS X 10.4.8.
I wonder if something in the way we launch/load when session retore is doing its thing triggers this more often?  After I started restoring a certain number of tabs on every launch, I've seen the wrong icon at every launch.
Don't know how Sam missed this when QAing bug 272534 ;)
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 272534
You need to log in before you can comment on or make changes to this bug.