All users were logged out of Bugzilla on October 13th, 2018

After middle clicking to scroll, if middle button is clicked again, a tab is opened with the URL "http:///"

RESOLVED DUPLICATE of bug 216899

Status

()

RESOLVED DUPLICATE of bug 216899
13 years ago
12 years ago

People

(Reporter: chiefaver, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Whenever I click the middle button to begin scrolling, I can click in any empty
area of the page and a new tab will be opened trying to navigate to the URL
"http:///".

I'm not sure if this just started happening, or if it has happened since I
started using FX 1.4, but it did not do this in 1.0.6(not sure about 1.0.7).

Reproducible: Always

Steps to Reproduce:
1. In a webpage, middle click on an empty area of the page, which will start the
scrolling thing(sorry, not sure what it's called.
2. Middle click in any other empty area of the page, but not on the scroll icon.

Actual Results:  
A new tab is opened with the URL "http:///".

Expected Results:  
Stopped the scrolling thing.

Comment 1

13 years ago
WFM - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20050925
Firefox/1.4

If you have not tried reproducing this bug in Firefox's safe-mode and creating a
new profile please do.
http://kb.mozillazine.org/Safe_mode
http://kb.mozillazine.org/Profile_manager#Command_line

Comment 2

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

I can reproduce this bug. The browser seems to paste the clipboard to the URL bar and navigate there. If the contents of the clipboard happen to be a URL, you'll be sent there as if you typed that URL and pressed enter.

Comment 3

13 years ago
I can reproduce this 100% of the time.  When middle-clicking on an "empty" part of a webpage to activate the autoscrolling thing, moving the mouse cursor in _any_ direction ever so slightly will load the contents of the clipboard content active tab address field and "activate" it.

This frequently results in random webpages being loaded when I'm browsing webpages and accidently hit the middle mouse button.  Loading webpages randomly could be a serious problem if inappropriate content is loaded at an inopportune time.

I know this sounds like a freak-type occurance, but this behavior occurs a few times a day for me.

Comment 4

13 years ago
(In reply to comment #3)
Are you using linux? If so then that is the correct default behavior. This issue is Windows only. Either way you can check the value of the preferences by typing about:config in the address bar, in the about:config filter bar type middle, find middlemouse.contentLoadURL and change it to false you also might want to set middlemouse.paste to false too. 

Comment 5

12 years ago
See 

Bug 274773 "Middle-clicking non-hyperlinked areas of a page attempts to 
load from clipboard"
Bug 229093 – pref to prevent middle-click paste in time interval after 
middle-mouse scroll

I can't tell whether the original report is actually thought to be a defect,
but this is probably a Dup of Bug 274773


Comment 6

12 years ago
Actually, this is a dupe of bug 216899.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 216899
You need to log in before you can comment on or make changes to this bug.