Many keyboard shortcuts and keys do not work

RESOLVED DUPLICATE of bug 305032

Status

()

RESOLVED DUPLICATE of bug 305032
13 years ago
13 years ago

People

(Reporter: udmattie, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

Sometimes copy, paste, home, end, and the cursor keys do not work while working
with text in the address bar and input fields within webpages.

Reproducible: Sometimes

Steps to Reproduce:
1.  Navigate to any URL on the web
2.  Try to use shift + home to highlight the text in the address bar
3.  Try to use cursor keys to move back and forth between text
4.  Try to copy or paste text using the keyboard shortcuts, ctrl+c and ctrl+p,
respectively.
5.  Try to use home key to move to home position in address bar.
6.  Try to use end key to move to end position in address bar.

Actual Results:  
1.  As expected.
2.  Text does not highlight and cursor does not move.
3.  Insertion cursor does not move.
4.  Text does not copy from or paste to address bar.
5.  Insertion cursor does not move.
6.  Insertion cursor does not move.

Expected Results:  
1.  As expected
2.  Insertion cursor moves to home position and the delta text is highlighted.
3.  Insertion cursor moves with the cursor keys.
4.  Text can be copied and pasted to and from Firefox and other programs.
5.  Insertion cursor moves to home position
6.  Insertion cursor moves to end position

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 305032 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
This bug not only occurs on subsequent instances, but also the first instance of
FireFox 1.5 beta as well.  I can now verify it as occuring all the time.
You need to log in before you can comment on or make changes to this bug.