Browser send url-data in cp1251 to UTF-8

RESOLVED DUPLICATE of bug 284474

Status

()

defect
RESOLVED DUPLICATE of bug 284474
14 years ago
14 years ago

People

(Reporter: s.korablin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

I have web site in cp1251 codepage (content="text/html; charset=windows-1251").
This site hav links like: http://sitename/view.php?name=xxxxxxx , where xxxxxxx
- some string in cp1251 encoding. If i try browse this link in firefox 1.5,
browser send "xxxxxx" srting to server in UTF8 encoding. This is wrong.

Reproducible: Always

Steps to Reproduce:
1. go to http://ladiosa.h15.ru/view.php?id=28
2. click to http://ladiosa.h15.ru/view.php?name=xxxxxxx link


Actual Results:  
Have page with data in cp1251 and utf8 (sended by browser) in same times.

Expected Results:  
Browser should send date in cp1251 codepage? because in page header set this
codepage.
IE6 and FireFox 1.0.7 working fine.

Comment 1

14 years ago
Related to bug 308159 and Core bug 284474?

*** This bug has been marked as a duplicate of 284474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.