If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

script and style tags together in a TD tag will cloak another TD

VERIFIED DUPLICATE of bug 28918

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 28918
18 years ago
18 years ago

People

(Reporter: Matthew Mastracci, Assigned: vidur (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.13 i686; en-US; m14)
BuildID:    2000030709

If you create a table with two columns, the left one containing empty script and
style tag pairs and the right containing text, you won't actually see anything.
I've broken the bug down under Mozilla to a base case that can't be broken down
any further. Since this happens if you've got any table cell containing both
script and style, I'd say this bug could occur frequently.  It also prevents
Mozilla users from browsing MSNBC properly.


Reproducible: Always
Steps to Reproduce:
1. Load the test attachment



Actual Results:  The page is empty

Expected Results:  The page should contain the word "blah"

<!-- test HTML: see attachment as well -->

<html><body>
<TABLE><TR>
<TD><script></script><style></style></TD>
<TD>blah</TD>
</TR>
</table>
</body></html>
(Reporter)

Comment 1

18 years ago
Created attachment 6271 [details]
Attachment with demo for convenience
(Reporter)

Comment 2

18 years ago
Okay...  some more bug data:

1.  It *only* happens when <script></script> comes before <style></style> and
only when they are both in there.
2.  Adding text in the script/style TD cell doesn't change anything
3.  Adding another pair of <script></script> doesn't seem to change anything either


Comment 3

18 years ago
Since script seems to be the main contributor reassigning to Vidur rather than 
Chris
Assignee: troy → vidur

Comment 4

18 years ago
This might have been fixed.  I see the text in the testcase, and MSNBC looks
just like NS 4.7 on my Linux build 2000.03.10.13.  Can you check with a new
build?
(Reporter)

Comment 5

18 years ago
This bug appears to be fixed, but it's definately a dup of bug 28918


*** This bug has been marked as a duplicate of 28918 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Marking verified dup of 28918.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.