Keyboard Keys occasionally act as shortcuts

RESOLVED DUPLICATE of bug 307375

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 307375
13 years ago
13 years ago

People

(Reporter: Rick Cusimano, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4

I've noticed that ocassionally certain keys don't do what they should.  ie the /
key becomes a shortcut to the 'search' bar at the bottom, and I've also had
problems with the arrow keys and ' key.

Tried it on two different machines, works fine most of the time but sometimes it
just refuses to function properly.

Reproducible: Sometimes

Comment 1

13 years ago
Could you clarify a bit.  For example, / is the shortcut for the search bar for
text.  What is it doing otherwise?  What are the arrow keys and ' doing (versus
what you expect)?

Comment 2

13 years ago
both the "/" and "'" key are intended to work as such.

http://www.mozilla.org/access/type-ahead/   states:
"Type a ' before your string to search only links. Type / before your string to
search all text."

These keys are chosen because they have [afaik] no other functions in browsers.
This is by design. Are there any other keys that act as shortcuts where you
didn't expect them or are these conflicting definitions?

If not, then this should be marked as INVALID.
(Reporter)

Comment 3

13 years ago
Allow me to explain what happened the other night.

I was completing a complicated online form and right at the end had to enter a
date in the format dd/mm/yyyy

I couldn't for the life of me enter a '/', and so the date was invalid.

The '/' key wouldn't work, it kept forcing the cursor into the 'search' box.  I
tried to copy one from another window, but CTRL+V wouldn't work either.

It seems to me that occasionally the keyboard goes into some strange 'mode' and
lots of things don't appear to work - the cursor keys, the 'home' and 'end' keys
etc.

It may be my mistake, but neither IE nor Firefox 1.0 ever did this.

If I can reproduce it again I'll try and post more information.

Comment 4

13 years ago
i've seen something similar when entering information in a form, where
everything i type just ends up in the search bar and i can't get out of "search"
mode, no matter what i try.

Only thing that seems to work is to quit Firefox.

Hard to reproduce behavior though, and i'm not sure if this has been filed by
someone else already, so i'm not chaning this to CONFIRMED yet.

I think the bug is not really the "/" or " ' " keys, but how Firefox separates
key input for forms to key input for control purposes.

Comment 5

13 years ago
Related to/duplicate of bug 307375?

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 307375 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.